Jump to content
pgdx

Den frie kafeen

Recommended Posts

Se der ja. Da har du integrert grafikk, viften går på 1962 rpm. Du har egen temp for hver kjerne, og de skal helst holdes innenfor 86 grader. Du kan monitorere både vifte hastighet og temperatur med psensor.

Mulig Thinkpad'en ikke støtter pwm for viftestyring. Nå er Thinkpads meget godt støttet på linux, så det bør ikke være noe problem. Installer pakken thinkfan:

# apt install thinkfan

manual-siden gir deg en grei oversikt:

https://manpages.debian.org/buster/thinkfan/thinkfan.1.en.html

Du kan styre direkte via /proc eller /sys (mulig begge er der hos deg). Her har du en gjennomgang med /proc:

http://www.thinkwiki.org/wiki/How_to_control_fan_speed

Usikker på hvor mye apt setter opp for deg når du installerer, så mulig du må inn manuelt å legge til en del. Du finner pekere bant annet her her:

http://x220.mcdonnelltech.com/ubuntu/

Kort fortalt, kan du legge inn og slå på kjernemodulen til thinkfan med (sjekk gjerne om det allerede er satt opp først):

# echo "options thinkpad_acpi fan_control=1" > /etc/modprobe.d/thinkpad_acpi.conf
# modprobe thinkpad_acpi
# systemctl enable thinkfan.service

Så kan du sjekke at den er satt opp til å starte ved oppstart:

# nano -w /etc/default/thinkfan

 

Edited by Del
Lagt til manuelt oppsett av demon.

Share this post


Link to post
3 hours ago, Del said:

Se der ja. Da har du integrert grafikk, viften går på 1962 rpm. Du har egen temp for hver kjerne, og de skal helst holdes innenfor 86 grader. Du kan monitorere både vifte hastighet og temperatur med psensor.

Mulig Thinkpad'en ikke støtter pwm for viftestyring. Nå er Thinkpads meget godt støttet på linux, så det bør ikke være noe problem. Installer pakken thinkfan:


# apt install thinkfan

manual-siden gir deg en grei oversikt:

https://manpages.debian.org/buster/thinkfan/thinkfan.1.en.html

Du kan styre direkte via /proc eller /sys (mulig begge er der hos deg). Her har du en gjennomgang med /proc:

http://www.thinkwiki.org/wiki/How_to_control_fan_speed

Usikker på hvor mye apt setter opp for deg når du installerer, så mulig du må inn manuelt å legge til en del. Du finner pekere bant annet her her:

http://x220.mcdonnelltech.com/ubuntu/

Kort fortalt, kan du legge inn og slå på kjernemodulen til thinkfan med (sjekk gjerne om det allerede er satt opp først):


# echo "options thinkpad_acpi fan_control=1" > /etc/modprobe.d/thinkpad_acpi.conf
# modprobe thinkpad_acpi
# systemctl enable thinkfan.service

Så kan du sjekke at den er satt opp til å starte ved oppstart:


# nano -w /etc/default/thinkfan

 

Tusen takk!

 

Thinkfan funket bra. En liten warning i /etc/thinkfan.conf

# ATTENTION: There is only very basic sanity checking on the configuration.
# That means you can set your temperature limits as insane as you like. You
# can do anything stupid, e.g. turn off your fan when your CPU reaches 70°C.
#
# That's why this program is called THINKfan: You gotta think for yourself.

:D

Jeg brukte samme forsiktige oppsett som han med x220 maskinen i linken din. Min t420 ble stille, så dette var en suksess :)

Nå ble det så stille at jeg hører kjøleskapet istedet :D:D

 

Edited by Stratleray

Share this post


Link to post
Annonse
Stratleray skrev (39 minutter siden):

Nå ble det så stille at jeg hører kjøleskapet istedet :D:D

Kult! Alltid er det noe. For oss som har pusset opp hus vet vi at vi aldri blir ferdige, alltid et rom som er verst 🙂 Meeeen, husk nerdens slagord: If it works, fix it!

Share this post


Link to post

Da har jeg fått skrudd sammen beistet. Satte i gang noen tunge simuleringer som bruker alle tråder, og full last på alle kjerner. Eneste jeg har stilt inn på i Bios er at minnet går på 3200MHz som oppgitt (en-klikk setting). Får omlad 4150MHz på alle kjerner ut-av-boksen på kontinuerlig last (ja, dette er last som stresser mer enn cinebench). Se skjermskudd. Etter å ha rotet litt rundt på nettet, må jeg vel si meg greit fornøyd. Ser ikke ut til at jeg kan forvente mer uten å overklokke.clock.png.080bdc930cf82043c496cdb959a962a6.png

Sjekket også hvor høyt hver kjerne klokket ved å kjøre full last på en CPU. Det kan gjøres enkelt med taskset. Bruk først top eller htop (eller en eller annen prosess-viewer) for å finne prosess-nummeret, PID, så er det bare å kjøre:

$ taskset -cp n PID

hvor n er mellom 0 og 31, altså hvilken CPU-kjerne, og PID er prosessnummeret. ET par av kjernene klokket rundt 4500MHz kontinuerlig, ingen klarte å holde 4700MHz kontinuerlig (som er max boost på 3950x).

Share this post


Link to post
1 hour ago, Del said:

Får omlad 4150MHz på alle kjerner ut-av-boksen på kontinuerlig last

Gratulerer! Ble du fornøyd med Noctua U12A kjøleren også? Du satt den vel opp som PWM i BIOS? Temps bra? :)

 

Share this post


Link to post
Betroz skrev (10 timer siden):

Gratulerer! Ble du fornøyd med Noctua U12A kjøleren også? Du satt den vel opp som PWM i BIOS? Temps bra? :)

 

Meget godt fornøyd. Den er stille som graven ved lett last, og bråker lite ved full last. Den styres fra Bios, og det ser ut til å funke bra. Får ikke lest temperaturer ennå, men oppnådde frekvenser på full last er en sterk indikator på OK temp. Jeg kjører Debian Stable, og der ser driveren ut til å være for gammel til å lese ut viftehastighet og CPU-temperatur fra dette hovedkortet (skjermkortet rapporterer fint). Da må jeg enten legge inn nyere kjerne, eller kompilere opp modulen selv. Ikke kommet så langt ennå.

Share this post


Link to post
1 hour ago, Del said:

Jeg kjører Debian Stable, og der ser driveren ut til å være for gammel til å lese ut viftehastighet og CPU-temperatur fra dette hovedkortet

Det er vel en ulempe med å kjøre Debian Stable, og det er med nyere hardware. 

Share this post


Link to post
Betroz skrev (21 minutter siden):

Det er vel en ulempe med å kjøre Debian Stable, og det er med nyere hardware. 

Jada, helt klart. Men nå har jeg tatt konsekvensen av det, og ligger unna alt som har med lukkede drivere å gjøre (les: Nvidia), så jeg kan enkelt slenge inn nyeste kjerne fra Debian Unstable ved siden av min Stable for testing. Har bare ikke kommet dit ennå.

Share this post


Link to post
6 minutes ago, Del said:

Men nå har jeg tatt konsekvensen av det, og ligger unna alt som har med lukkede drivere å gjøre (les: Nvidia)

Har du adoptert filosofien til slike som Richard Stallmann her? :wee:
Man får jo klart best ytelse med Nvidia sin lukkede driver fremfor Nouveau?

Share this post


Link to post
Betroz skrev (23 minutter siden):

Har du adoptert filosofien til slike som Richard Stallmann her? :wee:
Man får jo klart best ytelse med Nvidia sin lukkede driver fremfor Nouveau?

Stallman bashing? Da foreslår jeg at du setter deg inn i akkurat hva han mener, istedet for å basere deg på chills rundt om på nettet. Hvis du skal kritisere ham for filisofi rundt programvare, bør du være helt spesifikk på hva du mener. Dessuten har du helt feil adresse her, du mente kanskje Linus Torvalds?

Tror du glemte at jeg bruker RX580, altså AMD-grafikk. Der er nå åpen driver overlegen alle alternativer, og fullt på linje med den lukkede Nvidia driveren på windows. Helt spesifikt henger Nvidia driveren typisk etter, du kan typisk ikke bruke ny kjerne med lukket nvidia driver, og Nouveau får ikke nok informasjon fra Nvidia til å være brukbar. Dette gjelder uansett distro. Så hvis du vil leke med ny hardware på linux (eller blåse liv i gammel), ligg unna nvidia.

Share this post


Link to post
1 minute ago, Del said:

Stallman bashing? Da foreslår jeg at du setter deg inn i akkurat hva han mener, istedet for å basere deg på chills rundt om på nettet

Sorry...jeg spøkte bare med deg :)

Share this post


Link to post

Hovedkortet mitt har innebygd i225-v nettverkskort. Ubuntu 20.04 finner det uten problem, men f.eks Ubuntu MATE 20.04 gjør det ikke, selv om den er bygd oppå Ubuntu... Xubuntu 20.04 finner nettverkskortet, men etter oppstart av maskina er jeg koblet fra. Jeg må disable og enable den igjen for at det skal funke. Liksom WTF... Manjaro XFCE 20.03 har ikke dette problemet. Manjaro KDE 20.03 ville ikke installere engang.

Ahh gleden av ny hardware i Linux :D
(jada...gi det noen måneder, så skal dette løses. Heldigvis funker Windows 10 da)

Share this post


Link to post
Betroz skrev (57 minutter siden):

Hovedkortet mitt har innebygd i225-v nettverkskort. Ubuntu 20.04 finner det uten problem, men f.eks Ubuntu MATE 20.04 gjør det ikke, selv om den er bygd oppå Ubuntu... Xubuntu 20.04 finner nettverkskortet, men etter oppstart av maskina er jeg koblet fra. Jeg må disable og enable den igjen for at det skal funke. Liksom WTF... Manjaro XFCE 20.03 har ikke dette problemet. Manjaro KDE 20.03 ville ikke installere engang.

Ahh gleden av ny hardware i Linux :D
(jada...gi det noen måneder, så skal dette løses. Heldigvis funker Windows 10 da)

Det nettverkskortet bør funke, Intel startet å legg inn støtte for det i kjernen for to år siden. Kan være bios bugs som har fått work-around på driveren til windows. Vil du ha hjelp til feilsøk?

Kom et stykke til. La inn kjernen fra Debian Unstable, det er rimelig rett frem for oss som er kjent med Debian, Byttet ut Buster med Sid i kilde-fila, og installerte linux-image pakken. Den bootet opp uten problemer, og nå får jeg spenninger og temperaturer til prosessoren. Med full last på alle kjerner ligger temperaturen opp mot 68 grader, godt under 70 til enhver tid. Viften spinner opp så den høres, men forholdsvis støysvak likevel. Utfra alt jeg har sett på nettet om 3950x må jeg vel si meg godt fornøyd. Turbo-frekvensene jeg får er fullt på høyde med det folk som betaler dobbelt så mye for hovedkortet får. Kjøling er konkurransedyktig med en del vannkjølere, støysvak, og tar relativt liten plass i kabinettet. Nok en gang takk for tipset om den.

Share this post


Link to post
6 minutes ago, Del said:

Nok en gang takk for tipset om den.

:)

Du kan ordne deg egen vifteprofil i BIOS da for å senke støynivå enda et hakk.

Share this post


Link to post

Klarte å skvise den opp i 72.5 grader på ccd1 nå, og da bråket viften merkbart mer. Tung flyttallslast med vektorisering på alle tråder, så det er omtrent så tungt som min last vil være på det verste (vesentlig tyngre enn kompilering). Alle kjerner stabilt oppunder 4100MHz. Ser ut som vifteprofilen er akkurat der jeg vil ha den, så jeg tror jeg står over det nå.

Share this post


Link to post
8 hours ago, Del said:

Ser ut som nettverkskortet ditt har et firmware issue (kan tyde på at jeg hadde rett). Du kan bruke firmware for windows på linux, og få nettverkskortet ditt opp igjen:

 

Jeg oppgraderte firmware til nyeste rett etter jeg kjøpte hovedkortet i sommer, så jeg har allerede 1.45 firmware. Som jeg nevnte, Ubuntu 20.04 (standard Gnome versonen) hadde ikke problemet, det er de andre som er basert på den som bugger ut.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...