Jump to content
Andreaz69

CSV fil fra Excel, blir semikolon hver gang...

Recommended Posts

Hei,

Jeg sliter med å lagre et excel-ark som CSV der det er komma, og ikke semikolon som skilletegn.
Har søkt, og bl.a byttet permanent over til komma på PC´n etter denne guiden. (Win 7 og Excel 2007.)

Jeg har også en Mac, der jeg har Excel 2016. 

Jeg føler jeg har prøvd det meste, men når jeg titter på fila i tekst-editor etterpå, er det semikolon, uansett hva jeg velger av csv ms-dos, mac, kommaseparert osv.. 

Programmet jeg skal importere filer til, godtar kun .csv med komma som skilletegn.

Noen gode tips? :)

Share this post


Link to post
Andreaz69 skrev (1 time siden):

Har søkt, og bl.a byttet permanent over til komma på PC´n etter denne guiden. (Win 7 og Excel 2007.)

Du må vel velge punktum her for å få lov til å eksportere csv med komma som separator.

 

  • Like 1

Share this post


Link to post

Vet ikke i Excel men i LibreOffice Calc så lagrer den i .csv uten problemer. I hvertfall min erfaring at den type ting er mye lettere der.

Edited by Svein M

Share this post


Link to post

CSV separer ikke med semikolon, uansett hva du gjør, det er en komma-separert liste, slik at har du semikolon så var de trolig der fra før, eller så har du valgt noe merkelig?

Uansett, du kan bare erstatte de med komma, sånn -> https://jsfiddle.net/25xmctaf/

Edited by 0laf

Share this post


Link to post

Jeg vil tro at om komma skal brukes som skilletegn (CSV) så kan en ikke bruke komma som desimal skille tegn og tusen skille tegn.

Edit: Ser i post under at det går likevel.

Edited by Svein M

Share this post


Link to post
Svein M skrev (2 minutter siden):

Jeg vil tro at om komma skal brukes som skilletegn (cvs) så kan en ikke bruke komma som desimal skille tegn og tusen skille tegn.

Joa, må bare bruke quotes, som :

Jens, Mann, "43,44", osv

Share this post


Link to post

 

Andreaz69 skrev (2 timer siden):

Har søkt, og bl.a byttet permanent over til komma på PC´n etter denne guiden. (Win 7 og Excel 2007.)

 

Det du endrer da er separator for tusener eller desimaler (sic, artikkelens tittel) - Det du må endre på er innstillingen for 'Skilletegn' / 'List Delimiter' i systeminnstillingene.

Windows 7;

Sitat
You can change it in two ways:
 
1) Regional settings
 
Control Panel –> Clock, Language and Region –> Change the date, time, or number format
 
Click on Additional settings button.
 
2) Within Excel
 
Office Button (left hand corner) > Excel Options > Advanced > Editing Options > Uncheck 'Use system separators' > Define as per your needs

Like to answer questions which aren't answered for long time.

CSV-export fra Excel i Windows 10 bruker systeminstillingen for 'Skilletegn' / 'List Delimiter' - Sjekk hva som er satt der.

Norsk artikkel (Finn teksten i artikkelen): Endre liste skille tegnet for nye tekst filer (filer du oppretter når du eksporterer ved hjelp av lagre som)

Samme artikkel på engelsk:

Change the list separator for new text files (files you create when you export using Save As)

Dvs.

 

Sitat

Endre liste skille tegnet for nye tekst filer (filer du oppretter når du eksporterer ved hjelp av lagre som)

Når du lagrer en arbeids bok som en. CSV-fil, er standard liste skiller (skille tegn) et komma. Du kan endre dette til et annet skille tegn ved hjelp av innstillinger i Windows-området.

  1. Høyre klikk på Start -knappen i Microsoft Windows 10, og klikk deretter på Innstillinger.

  2. Klikk tid & språk, og klikk deretter område i det venstre panelet.

  3. Klikk ekstra dato, klokkeslett og regionale innstillingerunder Regionale innstillingeri hovedpanelet.

  4. Under områdeklikker du Endre dato, klokkeslett eller tall format.

  5. Klikk flere innstillingeri kategorien Format i dialog boksen område .

  6. Skriv inn et tegn som skal brukes som det nye skille tegnet i liste skille tegn i kategorien tall i dialog boksen Tilpass format .

  7. Klikk OK to ganger.

 

Andreaz69 skrev (4 timer siden):

Jeg har også en Mac, der jeg har Excel 2016. 

Tipper at det er noe tilsvarende på Mac, dvs. at du må inn og endre inne under 'Regional Settings'.

Share this post


Link to post

Takk for alle svar. @mobile999 hadde helt rett, det må velges punktum for at .CSV skal eksporteres med komma 🙃

Det kan jeg trygt si at jeg aldri hadde kommet til å prøve 😁


Til dere som foreslår søk og erstatt, så ja, i en tekst-editor som ikke ødelegger linjeskift osv, kunne jeg nok gjort det, men ville fortsatt at fila skulle komme ut av Excel uten ytterligere behov for redigering.

Jeg legger inn de data jeg trenger i excel i 3 kolonner, og ønsket å få de ut med komma mellom hver celleverdi.

Så problemet løst med @mobile999 sitt svar 👍

Edited by Andreaz69

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...