Jump to content
Zeppeluna

1-2 sekunders freeze/lag hvert 60-90 sekund. Hvordan feilsøke?

Recommended Posts

Hei, i online-spill (alle jeg har på steam, har ikke testet andre) opplever jeg lag omtrent hvert minutt. Det ser ut som network-lag, da spillere osv fortsetter å bevege seg rett frem, og jeg kan bevege meg fritt. Etter et sekund eller to spretter alt tilbake, og jeg er som regel blitt kverket iløpet av freezen. 

 

Noen mente det ikke var network-lag, men noe de kalte APM - at harddisken går i dvale pga inaktivitet, og må spinne opp igjen når spesifikke ressurser må loades, og at det da tar 1-2 sekunder hvor alt står stille. Jeg prøvde NoAPM for å skru av APM på alle harddisker og SSDer, og problemet ser ut til å fortsette.

 

Nå lurer jeg på om noen vet om et verktøy jeg kan kjøre samtidig som jeg spiller for å monitorere både disk og nettverk, så jeg kan finne ut hvor problemet ligger. F.eks kjøre et monitoreringsprogram på en skjerm nummer 2 og se etter spikes i nettverk eller disk-aktivitet når lagen forekommer.

 

På forhånd takk, folkens!

Share this post


Link to post

Du kan prøve å pinge et eller annet kontinuerlig, bra måte å sjekke om det er skikkelige spikes med jevne mellomrom.

 

Åpne CMD, skriv; ping (ip-adresse eller www.xxxx.xxx) -t

 

Jeg har brukt denne mye for å sjekke hvor mye jeg kan laste opp og ned mens jeg spiller for å ikke få lag. Det er stort sett greit å pinge www.google.com men hvis du finner IP til serveren så er jo det bedre. Dette er det enkleste du kan gjøre så start med det :)

 

Edit; For å sjekke ressursbruk så kan du bare ha oppgavebehandling/ task manager oppe, den er mer enn nøyaktig nok. Du bør også sette strømprofil til "maximum performance" (husker ikke hva det heter på norsk).

Edited by Belphegor

Share this post


Link to post

Jeg kjørte resource monitor ved siden av, og det er helt klart nettverket. Trafikken ligger jevnt på 50 kbps men stuper med jevne mellomrom til 0, før den gjør et lite hopp til 100, også flater ut på 50 igjen. 

 

Noen tanker om hva det kan være? Det er forresten på trådløst, men har foreløpig ikke noen god måte å trekke kabel til soverommet. Dessuten virker det så rart at det er så jevnt. Omtrent hvert minutt, pluss minus 15 sekunder, og det varer i ca. 1 sekund av gangen.

Share this post


Link to post
Annonse

Jeg kjørte resource monitor ved siden av, og det er helt klart nettverket. Trafikken ligger jevnt på 50 kbps men stuper med jevne mellomrom til 0, før den gjør et lite hopp til 100, også flater ut på 50 igjen.

 

Noen tanker om hva det kan være? Det er forresten på trådløst, men har foreløpig ikke noen god måte å trekke kabel til soverommet. Dessuten virker det så rart at det er så jevnt. Omtrent hvert minutt, pluss minus 15 sekunder, og det varer i ca. 1 sekund av gangen.

Selv om du ikke vil ha kabel, så burde du teste med kabel. Slik at du vet hvor problemet ligger. Blir laggen borte når du trekker kabel vet du jo at det er noe galt med wifi
  • Like 1

Share this post


Link to post

Beste er vel å starte med å se om du har pakke tap mens du spiller.. 

bare kjør ping -t "enellerannenipher"

Kan du forklare med nøyaktig hva du mener og hvordan man gjør det? Sliter med freezelag selv. Har ikke klart å finne noen løsning på over ett år.

:S

Share this post


Link to post

Åpne kommandovindu (Hvordan åpne ledetekst som administrator i Windows 8 eller 10).

Skriv ping -t 8.8.8.8

Du får noe slikt:

Pinging 8.8.8.8 with 32 bytes of data:
Reply from 8.8.8.8: bytes=32 time=12ms TTL=54
Reply from 8.8.8.8: bytes=32 time=11ms TTL=54
Reply from 8.8.8.8: bytes=32 time=12ms TTL=54
Reply from 8.8.8.8: bytes=32 time=11ms TTL=54
Reply from 8.8.8.8: bytes=32 time=13ms TTL=54
Reply from 8.8.8.8: bytes=32 time=12ms TTL=54
Reply from 8.8.8.8: bytes=32 time=11ms TTL=54

Det fortsetter så lenge du vil. Avbryt med Ctl-C.

Se etter eventuelle feilmeldinger.

Share this post


Link to post

Håper ikke dette går under "necro" åpning av en gammal tråd, men jeg har et litt "snodig" problem: jeg spiller wow og har litt problem med "heng" I spellet jeg tror skyldes en eller annen server. Maskina mi er oppdatert og fin fin. Linja er 300/300 linja fra eidsiva. Alt er oppdatert.

Mitt spørsmål: finnes det en eller annen utgave av MTR som måler pathping /traceroute i realtime? Kan litt i dis, men ikke så dreven på brytere. Evt om noen vet om et program som har en ui med tabeller/ grafer? Har kjørt en del mtr, men i wow så må jeg måle 3 forskjellige ip'er samtidig og det funker dårlig.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...