Jump to content
Ludvig86

Spørsmål ang. bygging av nettside og domene

Recommended Posts

Hvis man tester med html koden på w3scools så tar det 2 sekunder å finne feilen. Vet ikke om det går å poste html kode på dette forumet, men det går jo an å prøve.

Share this post


Link to post
Ludvig86 skrev (5 timer siden):

Hei igjen! 

Kjøpte domene hos Domeneshop til en grei årspris, og tenkte å lære meg HTML/CSS for å prøve å lage en side selv. Dette hadde jeg interesse for før i mine "yngre dager", så det er artig å friske opp dette i dag. 

Jeg ser en god del videoer og prøver å ta notater og lage meg ett "cheatsheet" som jeg kan bruke underveis i opplæringen. 

Men jeg har stått på noe jeg lurer på. 

I bildet under her, så blir "<" rød med en gang jeg skriver den,  og om jeg fortsetter å skrive, så blir "</body" rød, noe som indikerer feil. Men jeg klarer ikke å se hva det er som får opp feilmerkingen/rødfargen. 

Noen som har noen råd? 

 

Skjermbilde 2022-11-19 kl. 11.18.23.png

Skjermbilde 2022-11-19 kl. 11.18.35.png

Det programmet indikerer er nok bare at med en gang du skriver en påbegynnende tag (altså <), så validerer programmet HTML-koden din og sier at her er det en tag "uten innhold" og som ikke er avsluttet. Når du fortsetter å skrive skjønner programmet at du er "underveis" i påbegynte tag, men validerer HTML'en videre. Da skriker den om at du har en åpen tag (som ikke er avsluttet), men flytter fokuset til neste tag i HTML-koden, og det er tilfeldigivs </body>. Det er ikke noe å bry seg om. Kun til hjelp, slik at du skal huske på å skrive korrekt HTML-syntax. Straks du har skrevet ferdig (altså avsluttet img-tagen din) så vil du nok se at den rød-markerte </body> tagen blir blå igjen. For da er HTML-koden validert til å være korrekt syntax.

Edited by Fustasjeopphengsforkobling

Share this post


Link to post

Hei igjen! 

Siden jeg allerede har denne tråden så bare spør jeg her. 

Jeg sliter litt med å finne ut hva som er feil i kodene mine. 

Er i ferd med å lage en enkel hjemmeside for ett band, og prøver å få til en navigasjons-linje på toppen av siden. Men i CSS arket mitt får jeg ikke til å få frem det jeg vil på siden. 

Skal ikke bl.a. de sorte punktene bli borte, og teksten skal stå på en linje nå? Jeg klarer ikke å se hva som gjør at det ikke reagerer. 

Takk for innspill! 


 

Skjermbilde 2022-11-27 kl. 21.33.00.png

Skjermbilde 2022-11-27 kl. 21.33.12.png

Skjermbilde 2022-11-27 kl. 21.33.44.png

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...