Jump to content
Sign in to follow this  
Olstig

Edgerouter-X og altibox

Recommended Posts

Hei

 

Har kabel fra mediakonverter til min Edgerouter-X på port eth0.
Ønsker internett og iptv ut på eth1

 

Oppsettet mitt er i dag:
Hjemmesentral VGM -> TP-Link Switch -> 1stk kabel til tv dekoder Q22. - , og 1 kabel til playstation (internett)

Med dette oppsettet kjøres altså nett og iptv i samme kabel fra hjemmesentral til switch, hvor jeg kan hente ut det jeg måtte ønske fra switch.

Har prøvd meg frem og fått mye god hjelp, men nå står jeg litt fast. Internett fungerer, men tv hakker. Står også at tv er utilgjengelig, men nrk kanalene fungerer.

Dette er min config.. (Har fjernet MAC-adressen)

firewall {
    all-ping enable
    broadcast-ping disable
    ipv6-name WANv6_IN {
        default-action drop
        description "WAN inbound traffic forwarded to LAN"
        enable-default-log
        rule 10 {
            action accept
            description "Allow established/related sessions"
            state {
                established enable
                related enable
            }
        }
        rule 20 {
            action drop
            description "Drop invalid state"
            state {
                invalid enable
            }
        }
    }
    ipv6-name WANv6_LOCAL {
        default-action drop
        description "WAN inbound traffic to the router"
        enable-default-log
        rule 10 {
            action accept
            description "Allow established/related sessions"
            state {
                established enable
                related enable
            }
        }
        rule 20 {
            action drop
            description "Drop invalid state"
            state {
                invalid enable
            }
        }
        rule 30 {
            action accept
            description "Allow IPv6 icmp"
            protocol ipv6-icmp
        }
        rule 40 {
            action accept
            description "allow dhcpv6"
            destination {
                port 546
            }
            protocol udp
            source {
                port 547
            }
        }
    }
    ipv6-receive-redirects disable
    ipv6-src-route disable
    ip-src-route disable
    log-martians enable
    name WAN_IN {
        default-action drop
        description "WAN to internal"
        rule 10 {
            action accept
            description "Allow established/related"
            state {
                established enable
                related enable
            }
        }
        rule 20 {
            action drop
            description "Drop invalid state"
            state {
                invalid enable
            }
        }
    }
    name WAN_LOCAL {
        default-action drop
        description "WAN to router"
        rule 10 {
            action accept
            description "Allow established/related"
            state {
                established enable
                related enable
            }
        }
        rule 20 {
            action drop
            description "Drop invalid state"
            state {
                invalid enable
            }
        }
    }
    receive-redirects disable
    send-redirects enable
    source-validation disable
    syn-cookies enable
}
interfaces {
    ethernet eth0 {
        address dhcp
        description Internet
        duplex auto
        firewall {
            in {
                ipv6-name WANv6_IN
                name WAN_IN
            }
            local {
                ipv6-name WANv6_LOCAL
                name WAN_LOCAL
            }
        }
        speed auto
        vif 101 {
            address dhcp
            description IPTV
            dhcp-options {
                default-route no-update
                default-route-distance 210
                name-server update
            }
            mac XX:XX:XX:XX:XX
        }
        vif 102 {
            address dhcp
            description Internet
            firewall {
                in {
                    name WAN_IN
                }
                local {
                    name WAN_LOCAL
                }
            }
        }
    }
    ethernet eth1 {
        description Local
        duplex auto
        speed auto
    }
    ethernet eth2 {
        description Local
        duplex auto
        speed auto
    }
    ethernet eth3 {
        description Local
        duplex auto
        speed auto
    }
    ethernet eth4 {
        description Local
        duplex auto
        speed auto
    }
    loopback lo {
    }
    switch switch0 {
        address 192.168.1.1/24
        description Local
        mtu 1500
        switch-port {
            interface eth1 {
            }
            interface eth2 {
            }
            interface eth3 {
            }
            interface eth4 {
            }
            vlan-aware disable
        }
    }
}
protocols {
    igmp-proxy {
        interface eth0.101 {
            alt-subnet 172.21.0.0/16
            role upstream
            threshold 1
        }
        interface eth1 {
            alt-subnet 0.0.0.0/0
            role downstream
            threshold 1
        }
    }
}
service {
    dhcp-server {
        disabled false
        hostfile-update disable
        shared-network-name LAN {
            authoritative enable
            subnet 192.168.1.0/24 {
                default-router 192.168.1.1
                dns-server 192.168.1.1
                lease 86400
                start 192.168.1.38 {
                    stop 192.168.1.243
                }
            }
        }
        static-arp disable
        use-dnsmasq disable
    }
    dns {
        forwarding {
            cache-size 150
            listen-on switch0
        }
    }
    gui {
        http-port 80
        https-port 443
        older-ciphers enable
    }
    nat {
        rule 5000 {
            description "Masquerade LAN to WAN"
            log disable
            outbound-interface eth0.102
            protocol all
            source {
                address 192.168.1.0/24
            }
            type masquerade
        }
        rule 5010 {
            description "masquerade for WAN"
            outbound-interface eth0
            type masquerade
        }
    }
    ssh {
        port 22
        protocol-version v2
    }
}
system {
    host-name ubnt
    login {
        user XXX {
            authentication {
                encrypted-password XXXX/
            }
            level admin
        }
    }
    ntp {
        server 0.ubnt.pool.ntp.org {
        }
        server 1.ubnt.pool.ntp.org {
        }
        server 2.ubnt.pool.ntp.org {
        }
        server 3.ubnt.pool.ntp.org {
        }
    }
    syslog {
        global {
            facility all {
                level notice
            }
            facility protocols {
                level debug
            }
        }
    }
    time-zone UTC
}


 

Share this post


Link to post
2 hours ago, Olstig said:

protocols {
    igmp-proxy {
        interface eth0.101 {
            alt-subnet 172.21.0.0/16
            role upstream
            threshold 1
        }
        interface eth1 {
            alt-subnet 0.0.0.0/0
            role downstream
            threshold 1
        }
    }
}

 

Du vil nok få problemer med TV på andre porter enn eth1 ihvertfall.  Muligens på eth1 også, alt ettersom hvordan dette spiller sammen med switch0 configen din.

 

Bruker @trrunde har jo lagt ut en komplett ederouter conffig på https://github.com/trrunde/routerconfig/blob/master/edgerouter-x-altibox

 

Som du ser så er downstream interface satt til switch0.  Det kan også tenkes at du begrenser litt mye med ditt valg av alt-subnet på upstream.  Aner ikke...  Verdt å prøve med noe litt større dersom du fremdeles har problemer etter å ha endre downstream

Share this post


Link to post

Trenger bare en aktiv port på edgerouter siden jeg går videre via switch.

 

Får feilmelding på den oppskriften på github når det skal legge inn firewall på TV-IN.

 

når jeg kjører commit etter det feltet vil den ikke gjennomføre fordi det mangler regel på brannmur står det .. 

Share this post


Link to post

har ikke edgerouter selv, så jeg gjetter litt her.  Men du bør vel bare kunne droppe den referansen til TV-IN?  Det var tydeligvis ikke så komplett som jeg trodde.

Ellers har du vel også en kritisk mangel under nat?  Du må NATe både VLAN 101 og 102.

Og du må enten ha alt krimskramset rundt dhcp klienten på VLAN 101 (som sørger for at du får noen ruter fra DHCP-serveren), eller så må du legge inn disse rutene statisk.

 

Share this post


Link to post
Olstig skrev (9 timer siden):

Hei

 

Har kabel fra mediakonverter til min Edgerouter-X på port eth0.
Ønsker internett og iptv ut på eth1

 

Oppsettet mitt er i dag:
Hjemmesentral VGM -> TP-Link Switch -> 1stk kabel til tv dekoder Q22. - , og 1 kabel til playstation (internett)

Med dette oppsettet kjøres altså nett og iptv i samme kabel fra hjemmesentral til switch, hvor jeg kan hente ut det jeg måtte ønske fra switch.

Har prøvd meg frem og fått mye god hjelp, men nå står jeg litt fast. Internett fungerer, men tv hakker. Står også at tv er utilgjengelig, men nrk kanalene fungerer.

Litt usikker på hva du vil fram tid her.

Er det oppsettet "Hjemmesentral VGM -> TP-Link Switch -> 1stk kabel til tv dekoder Q22. - , og 1 kabel til playstation" som gir deg hakkete TV-bilder? Og så ønsker du å sette inn Edgerouter-X mellom VGM og TP-Link switch?

Vær klar over at switchen(e) du bruker mellom VGM og TV må støtte "IGMP snooping". Hvis den TP-Link-switchen din ikke gjør det, så får du hakkete TV-bilder. (Been there.) Det er mulig Edgerouter-X gjør det (eller kan konfigureres til det), men det fant jeg aldri ut: jeg kjøpte meg et par nye TP-Link-switcher istedet. (Og nå har jeg en ubrukt Edgerouter-X liggende.)

Share this post


Link to post
nebrewfoz skrev (2 timer siden):

Litt usikker på hva du vil fram tid her.

Er det oppsettet "Hjemmesentral VGM -> TP-Link Switch -> 1stk kabel til tv dekoder Q22. - , og 1 kabel til playstation" som gir deg hakkete TV-bilder? Og så ønsker du å sette inn Edgerouter-X mellom VGM og TP-Link switch?

Vær klar over at switchen(e) du bruker mellom VGM og TV må støtte "IGMP snooping". Hvis den TP-Link-switchen din ikke gjør det, så får du hakkete TV-bilder. (Been there.) Det er mulig Edgerouter-X gjør det (eller kan konfigureres til det), men det fant jeg aldri ut: jeg kjøpte meg et par nye TP-Link-switcher istedet. (Og nå har jeg en ubrukt Edgerouter-X liggende.)

Jeg ønsker å fjerne VGM, og kunne bruke Edgerouter-X på samme måte som jeg bruker VGM i dag. Altså TV og nett ut på samme port.
VGM fungerer slik i dag. Om jeg plugger  TV-dekoder inn i LAN1, LAN2, LAN3, LAN4 får jeg TV... Plugger jeg 4 datamaskiner inn på dem  får jeg internett.. Setter jeg en Switch i LAN1-3 så får jeg både TV og Internett ut av Switch... Via den den ene lan på vgm og en kabel mellom vgm og switch.

Switchen jeg har i dag støtter igmp snooping. Det er den samme som altibox anbefaler av switcher.  Kjører i dag 3 dekodere, og 3 forskjelige routere ut fra vgm. Alt fra LAN1..

 

Tenker det må være mulig å sette dette opp.. vgm klarer det, da burde egnderouteren også :)

Er ikke noe alternativ for meg å ha 2 kabler fra hjemmesentral.. Kan heller ikke splitte kabel siden jeg har 500/500 linje.. :)

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...