Jump to content
Sign in to follow this  
_hauken_

1557 og kvilemodus i Ubuntu

Recommended Posts

Heisann!

 

Beklagar om dette her vort svart på tidlegare, men eg fann i alle høve ikkje eit passande svar.

 

Eg har ei Tundra 1557E frå PSData som eg køyrer Ubuntu Hoary på. Maskina er basert på barebook-løysinga 1557 frå Aopen. Dette fungerer stort sett fint, bortsett frå at eg ikkje får maskina til å gå i kvilemodus. Dette er kjedeleg med ei berbar maskin med avgrensa batterikapasitet. Er det nokon som har løyst dette på nokon måte?

 

Om dette fungerer betre i andre distribusjonar, som til dømes Fedora eller Mandriva, kan eg gjerne bytte til ein av dei, om det er det som skal til.

 

Har nokon tips å kome med?

Share this post


Link to post
Heisann!

 

Beklagar om dette her vort svart på tidlegare, men eg fann i alle høve ikkje eit passande svar.

 

Eg har ei Tundra 1557E frå PSData som eg køyrer Ubuntu Hoary på. Maskina er basert på barebook-løysinga 1557 frå Aopen. Dette fungerer stort sett fint, bortsett frå at eg ikkje får maskina til å gå i kvilemodus. Dette er kjedeleg med ei berbar maskin med avgrensa batterikapasitet. Er det nokon som har løyst dette på nokon måte?

 

Om dette fungerer betre i andre distribusjonar, som til dømes Fedora eller Mandriva, kan eg gjerne bytte til ein av dei, om det er det som skal til.

 

Har nokon tips å kome med?

Les her

 

Jeg har 1557, og det funker ypperlig ;)

Share this post


Link to post

Ubuntu er den eneste distroen jeg har prøvd som faktisk fungerer med suspend to ram, og suspend to disk helt out of the box på min 1557! Hva er det som skjer når du prøver?

Share this post


Link to post
Ubuntu er den eneste distroen jeg har prøvd som faktisk fungerer med suspend to ram, og suspend to disk helt out of the box på min 1557! Hva er det som skjer når du prøver?

Når eg brukar System - Log out - Hibernate får eg fram det eg hadde på skrivebordet, dette er nok ein slags suspend to disc, og fungerer greit.

 

Men Fn - F2 som skal sende maskina i dvale (suspend to ram) eller berre å leggje att lokket fører ikkje til at noko skjer. Ved å late att maskina slår skjermen seg rettnok av, men eg får ikkje skikkeleg dvalemodus med svært lågt straumforbruk utanom når eg brukar hibernate, men då tek det desto lenger tid å starte opp att....

Share this post


Link to post

Hvilemodus har blit mye bedre i Utviklingsversjonen av ubuntu (Breezy badger). Den funger nå på min laptop- men den virka ikke på Hoary. Kan jo være verdt et forsøk..

Share this post


Link to post

Du må aktivere sleep først. Det er enkelt, bare åpne fila /etc/default/acpi-support og ta bort # som står forran "ACPI_SLEEP=true". Da dukker suspend opp i log out menyen, og Fn+F2 funker.

Share this post


Link to post
Du må aktivere sleep først. Det er enkelt, bare åpne fila /etc/default/acpi-support og ta bort # som står forran "ACPI_SLEEP=true". Da dukker suspend opp i log out menyen, og Fn+F2 funker.

Dette funker ikke hos meg. Sitter med en 1557.

Det som skjer er at når jeg trykker Fn+F2 så piper maskina (aldri en god ting..), for så etterhvert gå i hvilemodus. Men når jeg skal vekke den igjen så blir skjermbildet helt merkelig. Fullt av farger og kaos. Noen som har vært borti noe lignende?

Share this post


Link to post
Du må aktivere sleep først. Det er enkelt, bare åpne fila /etc/default/acpi-support og ta bort # som står forran "ACPI_SLEEP=true". Da dukker suspend opp i log out menyen, og Fn+F2 funker.

Dette fungerer flott for meg! Takk skal du ha!

Share this post


Link to post
jeg bruker ati sine.

Jeg har ikke brukt ati sine drivere selv, i ubuntu, så dette er ikke garantert å hjelpe. Men åpne fila /etc/acpi/prepare.sh, og titt mot slutten. Der finner du noen linjer som er kommentert ut:

# And then try to save some video state
#if [ x$SAVE_VBE_STATE = "xtrue" ]; then
#  VBESTATE=`tempfile`
#  vbetool vbestate save >$VBESTATE;
#fi

Fjern # på alle linjene, og se om sleep fungerer bedre.

Share this post


Link to post

Det fungerer mye bedre! Takk skal du ha. Fn+F2 kjører maskina i sleep, så må jeg trykke på 'på-knappen' (i windows var d nok å touche touchpaden, men d er greit) da går skjermen først i et fargesprak før jeg får en loginskjerm, jeg logger inn og alt er såre vel

Men hvis jeg lukker skjermen så fungerer det ikke helt, får da bare 'lock-screen' ser d ut som?

Share this post


Link to post
Det fungerer mye bedre! Takk skal du ha. Fn+F2 kjører maskina i sleep, så må jeg trykke på 'på-knappen' (i windows var d nok å touche touchpaden, men d er greit) da går skjermen først i et fargesprak før jeg får en loginskjerm, jeg logger inn og alt er såre vel

Men hvis jeg lukker skjermen så fungerer det ikke helt, får da bare 'lock-screen' ser d ut som?

Prøv å bytt ut "action=/etc/acpi/lid.sh" med "action=/etc/acpi/sleep.sh" i /etc/acpi/events/lidbtn.

:)

Share this post


Link to post
Prøv å bytt ut "action=/etc/acpi/lid.sh" med "action=/etc/acpi/sleep.sh" i /etc/acpi/events/lidbtn.

Det fungerte jo som fot i hose! Etter at jeg restarta maskina kunne jeg klappe sammen så mye jeg ville! Faktisk fungerer det så bra at maskina våkner når jeg åpner lokket igjen (trenger ikke bruke på-knappen slik jeg må med Fn+F2).

Tusen takk igjen!

Litt ekkelt at skjermen først blir fargegal, men det kan jeg vel leve med.

Share this post


Link to post
Det fungerte jo som fot i hose! Etter at jeg restarta maskina kunne jeg klappe sammen så mye jeg ville! Faktisk fungerer det så bra at maskina våkner når jeg åpner lokket igjen (trenger ikke bruke på-knappen slik jeg må med Fn+F2).

Tusen takk igjen!

Litt ekkelt at skjermen først blir fargegal, men det kan jeg vel leve med.

Flottings, bare hyggelig å hjelpe! Skjermen får rare farger hos meg og, så det er vel noe vi må leve med inntill videre. Ser fjernt ut, men det gjør heldigvis ingen skade. :)

Share this post


Link to post

Av ein eller annan grunn ser det ut til at eg får problem med musa når maskina vaknar frå dvale. Musepeikaren bevegar seg mykje raskare enn normalt, og rullehjulet verkar ikkje. Om eg koplar musa frå og til igjen, er alt som normalt.

 

Samstundes tykkjer eg vifta går oftare etter at eg gjorde denne endringa.

 

Nokon som har opplevd noko liknande og har tips?

Share this post


Link to post

Jeg fikk sleep til å fungere nå, (også når jeg lukker lokket).

Men hva innebører egentlig sleep? Hvor mye batteri bruker den da?

 

Hvordan skiller det seg fra suspend og hibernate?

Er suspend to disc det samme som hibernate?

Verken suspend eller hibernate fungerer her, med suspend henger den bare mens med på hibernate får jeg kernel panic (tror det er fordi den har en annen cpuhastighet når den starter enn når den slo seg av?)

Share this post


Link to post

Sleep = suspend to ram, skrur av maskinen, men lar minne beholde strøm.

Hibernate = suspend to disk, skrur maskinen av totalt, og lagrer innholdet av ram til disk.

 

Så med sleep brukes ganske lite strøm, men hvor mye vet jeg ikke.

 

Når det gjelder problemene deres så har jeg ikke peiling.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...