Jump to content
Sign in to follow this  
JohnRichard

CSS grayscale på bilder *#3*

Recommended Posts

Hei!

 

Dette funker kun i IE, finnes det en standardsak som gjør det samme?

 

a img {
 filter: gray;
}

a:hover img {
 filter: none;
}

Edited by JohnRichard

Share this post


Link to post
Hei!

 

Dette funker kun i IE, finnes det en standardsak som gjør det samme?

 

a img {
 filter: gray;
}

a:hover img {
 filter: none;
}

Bruk vanlig css rollover! Da er du sikker på at det fungere i de fleste

browsere. Du kan leke deg i alpha channel, men støtten er minimal.

Edited by kvikks

Share this post


Link to post

OK, nå har jeg kommet ett steg videre. (Takk kvikks!)

 

Noen som vil sjekke siden min og se på koden (spesielt CSS).

 

Det jeg nå lurer på er om jeg må lage like mye kode til hvert menyvalg, som jeg har gjort på "dataweb", eller om dere kloke hoder har en bedre ide?

 

LINK!

 

På forhånd takk for hjelpen!

Share this post


Link to post

Ble fasinert over måten du løste det på. Men om man skulle hatt samme utseende på et bildegalleri. Og da altså ikke kan ha en egen class til hver link, og heller ikke ha hvert bilde slik som du har det(et svart/hvitt og et farget i et). Kan det løses da? eller er det en umulig oppgave? Spør altså etter en alternativ måte å gjøre det på som kan fungere i bildegalleri der det lastes opp bilder regelmessig.

Share this post


Link to post
Ble fasinert over måten du løste det på. Men om man skulle hatt samme utseende på et bildegalleri. Og da altså ikke kan ha en egen class til hver link, og heller ikke ha hvert bilde slik som du har det(et svart/hvitt og et farget i et). Kan det løses da? eller er det en umulig oppgave? Spør altså etter en alternativ måte å gjøre det på som kan fungere i bildegalleri der det lastes opp bilder regelmessig.

 

slettet

 

*begynne å lese post :blush:

Edited by kvikks

Share this post


Link to post

 

Denne funksjonen trøbler på windows 2000 med IE6 (siste ver).

 

Her på jobb opplever jeg flimring på bildene, mens på jobben til en kamerat, så lastes bildet ned på nytt hver gang han tar musa over ett bilde ??!

 

Testet workarounden (example2), men den vil ikke virke med mitt bilde. Why? Fordi mitt er jpg, mens .gif er brukt i eksempelet ?!

 

Ser for meg ut som om denne løsningen ikke er noe grei på eldre windows maskiner med nyeste IE. Opera på disse OSene er seff alt okay!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...