Jump to content
RuneTh666

Excel. HVIS-funksjon (eller bedre)

Recommended Posts

Tverrfaglig Merkesystem er for de som ikke kjenner systemet bassert på at "alt" som er av ting på et bygg benevnes med en kode.
I jobben så bruker jeg TFM ganske mye for merking så jeg kunne tenkt meg å fått lagt inn et ark i filen jeg sender til de som lager merkeskilt for meg hvor de kodene + tekst jeg bruker blir skrevet inn sånn at når jeg skriver kode i "bestillingarket" så dukker teksten opp i nabokolonnen.
På den måten så sparer jeg meg for litt arbeid pluss at jeg vet at tekst og kode hører sammen.

 

Eksempler på koder med tilhørende tekst (kode etterfølges av et nummer som varierer):

BI = ISLOLASJON

DL = LUKE

FA = VENTILERT ARBEIDSPLASS

FF = FRYSEROM

FK = KJØLEROM

IK = KJØLEAGGREGAT

IV = AGGREGATENHET

JK = KOMPRESSOR

JP = PUMPE

JV = VIFTE

JW = SPESIALVIFTE

KA = AKTURATOR

KD = DRIVHJUL / DREV

KK = KANAL

LB = VARMEVIFTE

LC = KJØLEVIFTE

LD = KJØLEBAFFEL

LK = KJØLEBATTERI

LR = FREKVENSOMFORMER

LU = BEFUKTER

LV = VARMEBATTERI

LX = VARMEGJENVINNER

MA = ABSOLUTTFILTER

MB = KRIGSFILTER

MC = UV-FILTER

ME = ELEKTROSTATFILTER

MF = LUFTFILTER

MG = FETTFILTER

MR = RIST

MS = SYKLONFILTER

QD = FILTERVAKT

QL = LYDFELLE

QR = ROTASJONSVAKT

RD = TRYKKGIVER

RH = FUKTFØLER

RI = TERMOMETER

SQ = VAV

SK = CAV

SR = REGULERINGSSPJELD

SS = STENGESPJELD

SZ = BRANNSPJELD

 

Ark "Bestilling":

B11 -> B150: Her skriver jeg inn kode + nummer

A11 -> A150: Her skriver jeg inn tekst i dag

 

Ark "Komponentliste":

A3 -> : Her tenker jeg å skrive tekst

B3 -> : Her tenker jeg å skrive inn koden

 

 

Eksempel:

Ved utfylling av B11 i "Bestilling" så skriver jeg JV401 og da kommer "VIFTE" opp i A11

 

Share this post


Link to post

Sjekk ut SWITCH (https://www.techonthenet.com/excel/formulas/switch_ws.php)

 

Burde være det du ser etter.

 

På siden linket over viser de et eksempel med navn->nettside som kobling. Du erstatter med kode->tekst i ditt tilfelle.

 

Edit: Ble nysgjerrig på hvordan det funka i praksis så lagde et lite eksempel, sjekk vedlegg.

Eksempel.xlsx

Edited by PopcornFest

Share this post


Link to post

Lag en liste over hva forkortelsene betyr og bruk "slå.opp", men kun med de to første bokstavene.

I A11 blir formelen noe slikt som =slå.opp((deltekst(B11;1;2;)A3:B40)

 

Der A3:B40 er hvor du har listen

Share this post


Link to post

Sjekk ut SWITCH (https://www.techonthenet.com/excel/formulas/switch_ws.php)

 

Burde være det du ser etter.

 

På siden linket over viser de et eksempel med navn->nettside som kobling. Du erstatter med kode->tekst i ditt tilfelle.

 

Edit: Ble nysgjerrig på hvordan det funka i praksis så lagde et lite eksempel, sjekk vedlegg.

Funker nesten :-)

Siden koden vil etterfølges av ett nummer som varierer så ble det mye ukjent kode

Share this post


Link to post

Funker nesten :-)

Siden koden vil etterfølges av ett nummer som varierer så ble det mye ukjent kode

Leste spørsmålet ditt litt raskt; aklla sin metode er mye bedre! :D

Share this post


Link to post

Lag en liste over hva forkortelsene betyr og bruk "slå.opp", men kun med de to første bokstavene.

I A11 blir formelen noe slikt som =slå.opp((deltekst(B11;1;2;)A3:B40)

 

Der A3:B40 er hvor du har listen

 

Prøver lykken og ser hva som skjer. Kanskje jeg får kontakt med Marsboere i samme slengen :-D

Share this post


Link to post

Fant litt feil der, SLÅ.OPP(DELTEKST(B11;1;2);Komponentliste!A1:B40)

B11 skriver du inn bestillingskoden(f.eks JV401), A1:B40 er hvor listen i førsteposten ligger.

 

Edit jeg postet den første mer som ett eksempel, ikke en ferdig formel ;)

Edited by aklla

Share this post


Link to post

Prøv denne formelen i A11 og kopier nedover.

=HVISFEIL(INDEKS(Komponentliste!$A$3:$B$1000;SAMMENLIGNE(DELTEKST($B11;1;2);Komponentliste!$B$3:$B$1000);1);"")

 

Slå opp fungerer kun når koden står i første kolonne.

 

Edit: Legger ved eksempel da jeg kanskje misforstod det med komponentlisten?

 

Test.xlsx

Edited by trn100

Share this post


Link to post

Prøv denne formelen i A11 og kopier nedover.

 

=HVISFEIL(INDEKS(Komponentliste!$A$3:$B$1000;SAMMENLIGNE(DELTEKST($B11;1;2);Komponentliste!$B$3:$B$1000);1);"")

 

Slå opp fungerer kun når koden står i første kolonne.

 

Edit: Legger ved eksempel da jeg kanskje misforstod det med komponentlisten?

 

 

Hei trn100, likte formelen din  :) Manglet bare en 0 i den for eksakt treff. (markert med fet skrift)

 

=HVISFEIL(INDEKS(Komponentliste!$A$3:$B$1000;SAMMENLIGNE(DELTEKST($B11;1;2);Komponentliste!$B$3:$B$1000;0);1);"")

 

Mvh

RA

Share this post


Link to post

Hei trn100, likte formelen din  :) Manglet bare en 0 i den for eksakt treff. (markert med fet skrift)

 

=HVISFEIL(INDEKS(Komponentliste!$A$3:$B$1000;SAMMENLIGNE(DELTEKST($B11;1;2);Komponentliste!$B$3:$B$1000;0);1);"")

 

Mvh

RA

Det har du helt rett i ja, selv om det kanskje ikke gjør all verdens forskjell når man bare sammenligner 2 karakterer!  :)

Edited by trn100

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...