Jump to content
Sign in to follow this  
ve_gard

Hvorfor får jeg ikke lastet inn php5 modulen?

Recommended Posts

Jeg skal kjøre Apache 2.2 med PHP 5.0.. men har noen problemer..

 

Her er feilmeldingen jeg får når jeg starter Apacheserveren:

 

httpd.exe: Syntax error on line 115 of C:/apache/conf/httpd.conf: Cannot load C:/php/php5apache2.dll into server: Den angitte modulen ble ikke funnet.

 

 

...og jeg har skrevet inn:

LoadModule php5_module c:/php/php5apache2.dll i httpd.conf på riktig plass.

 

mvh Vegard

Share this post


Link to post

Jeg siterer Juke i en annen tråd her på forumet:

 

Meget fin artikkelserie.  :thumbup: 

 

Jeg har forøvrig en kommentar angående installeringen av PHP/Apache, som i allefall gjelder for oss Windowsbrukere (Windows XP Home om ikke annet).

 

Man vil kjøre seg fast i installasjonen dersom man benytter den nyeste versjonen av Apache (2.2.x) og foretar en manuell installasjon av PHP som forklart i artikkelen, da Apache kommer med en feilmelding i forbindelse med PHP når man prøver å starte serveren. Feilmeldingen forteller forøvrig ingenting om hva grunnen er, det står bare at oppstarten har feilet.  :ohmy:

 

Feilen skyldes ikke at det står noe feil i artikkelen her i HW, bare så det er sagt, det ser ut til å skyldes at den nyeste versjonen av Apache ikke uten videre er kompatibel med den nyeste versjonen av PHP (på Windows XP Home i allefall). Her er et utdrag fra en forumpost på php.net som forklarer hva som forårsaker problemet:

If you use Apache 2.2.x, the included DLLs (php4apache2.dll and php5apache2.dll) will not work for you as they are specific to the Apache 2.0.x API. There is an open bug report to address this issue but if you can't wait then go to the following URL and download an appropriate DLL for Apache 2.2.x:

 

* http://apachelounge.com/

 

The PHP Group does not endorse this site but it appears useful, so use it :-)

Her er en direktelink til siden med denne forumposten.

 

Løsningen inntil videre er stort sett å laste ned en oppdatert versjon av php5apache2.dll, slik at man får en utgave som støtter Apache 2.2.x, det står litt om fremgangsmåten med link og slikt på apachelounge.com.

 

Helt konkret finnes informasjonen om dette her, med nedlastingslinker og hele pakken. Jeg støtte på nettopp dette problemet selv, men fikk det til å fungere etter å ha fulgt instruksene på denne nettsiden. Dette bør kanskje nevnes i artikkelen?

6590064[/snapback]

 

Denne posten hjalp meg med å få PHP5-modulen til å fungere skikkelig.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...