Jump to content
Sign in to follow this  
hemo

Ubuntuproblem: Desktop kjem ikkje opp

Recommended Posts

Eg aktiverte automatisk innlogging på ein Ubuntu, som fungerte fint...

No nekter den å lasta desktop/skrivebord.

Musa er der, og eg kan ta Ctrl+Alt+F1 for å få opp kommandovindauge (som eg ikkje hugsar korleis eg kjem ut av).

 

Finnes det feilsøkings tips ein stad?

Share this post


Link to post

Failsafe?

Ctrl+Alt+Backspace gjev loginprompt, men etter brukarnamn og passord, kjem det ikkje opp noko skrivebord. Berre musepila...

 

PS! Grub seier at eg kan trykka Esc, og så f.eks. ta Ubuntu, kernel 2.6.12-10-386 (recovery mode). Er dette såkalla "failsafe"?

 

Resultatet er såfall ein kommandoprompt...

Share this post


Link to post

Då fekk eg opp X, som har litt anna bakgrunn.

Elles er alt likt.

Ingen desktop, berre musepeikar...

 

Edit: bump

Edited by hemo

Share this post


Link to post

Altså kjem det framleis ikkje noko skrivebord opp, etter at eg loggar inn eller tar startx i recovery mode. Skal eg formatera og installera Ubuntu på ny?

Share this post


Link to post

Strange!

Det fungerer ikkje no heller...

Eg starta ikkje på ny mellom dei to kommandoane, altså... men maskina jobba masse, og det såg ut til å ha gått bra... bare at eg ikkje får opp noko skrivebord :-s

 

Har du kommandoen for å installera KDE på same måte?

Share this post


Link to post

ja, nei... eg har nok ikkje tulla med nokon ting...

cd ~/.gnome
ls -al
cd gnome-vfs
ls -al
15 byte stor .trash_entry_cache

Var det noko der eg skulle sletta?

PS! Eg fann ingen andre mapper enn den gnome-vfs, under ~/.gnome

 

Elles kan eg sei at installasjon av KDE ikkje hjalp.

Eg får KDE loginprompt, får logga inn utan problem, og får opp KDE bakgrunnsbilde, men så er det stopp.

 

Ingen skrivebord :-(

Share this post


Link to post

Det skal ikkje vera naudsynt å gjera noko så stort som reinstall. Fjern

config-filer, så startar du GDM på nytt. Les logg-filar og sei oss kva som står.

 

ls /var/log (finn relevante ting her, og post det)...

Share this post


Link to post

Du kommer tilbake med Alt-F7. Bruker du KDM eller GDM?

 

Hvis du går inn i /etc/gdm/ og åpner filen gdm.conf, kan du prøve i første omgang å disable automatisk innlogging ved å endre til følgende:

[daemon]
# Automatic login, if true the first local screen will automatically logged
# in as user as set with AutomaticLogin key.
AutomaticLoginEnable=false
AutomaticLogin=

Share this post


Link to post

I innlogginsskjermen til KDE, kan eg klikka Menu og console login.

Når eg tar

cd ~

rm -rf .*

 

..kjem det opp:

rm: cannot remove `.' or `..'

rm: cannot remove `.' or `..'

 

Når eg tar dette:

cd ~

ls -al

 

..kjem det berre opp Desktop (som er tom) og Musikk (som er ei mappa med musikk som eg har lagt der).

 

Eg finn såfall ingen fleire filer eg kan sletta (ikkje med min begrensa linuxkunnskap, såfall), og skrivebordet dukkar ikkje opp att :-(

Share this post


Link to post
Det skal ikkje vera naudsynt å gjera noko så stort som reinstall. Fjern

config-filer, så startar du GDM på nytt. Les logg-filar og sei oss kva som står.

 

ls /var/log  (finn relevante ting her, og post det)...

5404510[/snapback]

Eg trur reinstall er naudsynt når ein har liten kunnskap om linux.

 

Men før eg gjer det:

 

1 - Filer under /var/log som har dato og tid som kan passe, er:

acpid

auth.log

btmp

daemon.log

debug

dmesg

evms-engiene.log

faillog

kdm.log

kern.log

lastlog

messages

scrollkeeper.log

syslog

wtmp

Xorg.0.log

 

2 - Så vidt eg veit, kan eg ikkje putta desse filene til detta forumet frå kommandoprompten i linux. Eg kan rett nok pinga ut, så maskina er på nett... Kanskje eg kan puta log-filer til ein ftp-server, og så plukka filene opp frå ein fungerande maskin?

Share this post


Link to post
Du kommer tilbake med Alt-F7. Bruker du KDM eller GDM?

 

Hvis du går inn i /etc/gdm/ og åpner filen gdm.conf, kan du prøve i første omgang å disable automatisk innlogging ved å endre til følgende:

[daemon]
# Automatic login, if true the first local screen will automatically logged
# in as user as set with AutomaticLogin key.
AutomaticLoginEnable=false
AutomaticLogin=

5404674[/snapback]

 

For å endra /etc/gdm/gdm.conf, prøver eg (for andre gong) å ta i bruk vim:

 

vim /etc/gdm/gdm.conf

..så blar eg til linja og tar i for Insert.

Når eg har redigert ferdig, tar eg

 

[Esc]:wq!

 

..og får:

"/etc/gdm/gdm.conf" E212: Kan ikke åpne fil for skriving

 

Ehh... korleis omgår eg dette?

 

PS! Eg hadde "GDM" og har no installert "KDM" for å prøva å løysa problemet. Det manglande skrivebordet ser ikkje ut til å ha noko med GDM eller KDM å gjer.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...