Jump to content
RickyG

Excel - ANTALL.HVIS vil ikke fungere når jeg har flere ark

Recommended Posts

Jeg har 5 ark (Hoved 1, 2, 3, 4) i et excel dokument.

 

Første arket har jeg formelen:

 

=ANTALL.HVIS('1:4'!A1;A1)

I cellen A1 har jeg et tall, i dette tilfellet 2.

 

På ark 1, 2, 3 og 4 har jeg litt forskjellige tall, men tallet 2 står på 3 av arkene.

 

Utifra hva jeg kan forstå så skal formelen gi svaret 3 da (2 tallet finnes 3 ganger)

 

Jeg får kun opp #VERDI! som svar. Prøvd det meste, men får det ikke til.

 

Setter jeg opp denne formelen:

=ANTALL.HVIS(D9:H9;A1)

 

Og legger inn verdier i D9 til H9 på samme ark, så fungerer det.

 

Noen tips til hvordan jeg kan få det til å fungere når det gjelder flere ark?

 

 

Share this post


Link to post

Hei

 

Celleområder over flere ark heter 3D-referanser (3D references, i tilfelle du vil google). Ikke alle regnearkfunksjoner støtter disse, så her du må nok gjøre opp for ett og ett ark først.

 

Beste hilsen Harald

Share this post


Link to post
Annonse

Hei

 

Celleområder over flere ark heter 3D-referanser (3D references, i tilfelle du vil google). Ikke alle regnearkfunksjoner støtter disse, så her du må nok gjøre opp for ett og ett ark først.

 

Beste hilsen Harald

Det vises jo mange eksempler på nettet, bla den som brukeren over meg henviser til og her bla: https://www.extendoffice.com/documents/excel/2541-excel-countif-across-multiple-worksheets.html

 

Men samme hva jeg gjør så ender jeg opp med #VERDI!, #NAVN? eller #REF!

Share this post


Link to post

Det er vrient å veilede videre uten å vite hva du kan. Men #VERDI betyr gjerne at du har feil datatype ett eller annet sted, for eksempel å prøve å gange et tall med en bokstav. Alternativt at du prøver på noe umulig, som innledningsvis. #NAVN betyr at Excel ikke kjenner igjen funksjonen du har satt inn, typisk problem ved å lime inn engelske løsninger i norskspråklig Excel. #REF betyr at en formel henviser til noe som ikke finnes, type =A5+A8, og så slette rad 8.

 

Hvis dette seriøst gjelder fire ark, kan du ikke bare ha en ANTALL.HVIS i hvert av dem og summere?

 

Beste hilsen Harald

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...