Gå til innhold

Foto

Excel - ANTALL.HVIS vil ikke fungere når jeg har flere ark


4 svar i denne tråden

#1 RickyG

RickyG

    Bruker

  • Medlemmer
  • 3 864 innlegg
  •   28. august 2005

Skrevet 8. august 2019 - 14:22

Jeg har 5 ark (Hoved 1, 2, 3, 4) i et excel dokument.

 

Første arket har jeg formelen:

 

=ANTALL.HVIS('1:4'!A1;A1)

I cellen A1 har jeg et tall, i dette tilfellet 2.

 

På ark 1, 2, 3 og 4 har jeg litt forskjellige tall, men tallet 2 står på 3 av arkene.

 

Utifra hva jeg kan forstå så skal formelen gi svaret 3 da (2 tallet finnes 3 ganger)

 

Jeg får kun opp #VERDI! som svar. Prøvd det meste, men får det ikke til.

 

Setter jeg opp denne formelen:

=ANTALL.HVIS(D9:H9;A1)

 

Og legger inn verdier i D9 til H9 på samme ark, så fungerer det.

 

Noen tips til hvordan jeg kan få det til å fungere når det gjelder flere ark?

 

 


  • 0

#2 Harald Staff

Harald Staff

    Bruker

  • Medlemmer
  • 2 417 innlegg
  •   25. april 2005

Skrevet 8. august 2019 - 14:54

Hei

Celleområder over flere ark heter 3D-referanser (3D references, i tilfelle du vil google). Ikke alle regnearkfunksjoner støtter disse, så her du må nok gjøre opp for ett og ett ark først.

Beste hilsen Harald
  • 0

#3 asdffdsa

asdffdsa

    Bruker

  • Medlemmer
  • 49 innlegg
  •   20. mai 2005

Skrevet 8. august 2019 - 14:58

Du kan ta en titt her: https://exceljet.net...entire-workbook


  • 0

#4 RickyG

RickyG

    Bruker

  • Medlemmer
  • 3 864 innlegg
  •   28. august 2005

Skrevet 8. august 2019 - 20:31

Hei

Celleområder over flere ark heter 3D-referanser (3D references, i tilfelle du vil google). Ikke alle regnearkfunksjoner støtter disse, så her du må nok gjøre opp for ett og ett ark først.

Beste hilsen Harald

Det vises jo mange eksempler på nettet, bla den som brukeren over meg henviser til og her bla: https://www.extendof...worksheets.html

 

Men samme hva jeg gjør så ender jeg opp med #VERDI!, #NAVN? eller #REF!


  • 0

#5 Harald Staff

Harald Staff

    Bruker

  • Medlemmer
  • 2 417 innlegg
  •   25. april 2005

Skrevet 9. august 2019 - 12:48

Det er vrient å veilede videre uten å vite hva du kan. Men #VERDI betyr gjerne at du har feil datatype ett eller annet sted, for eksempel å prøve å gange et tall med en bokstav. Alternativt at du prøver på noe umulig, som innledningsvis. #NAVN betyr at Excel ikke kjenner igjen funksjonen du har satt inn, typisk problem ved å lime inn engelske løsninger i norskspråklig Excel. #REF betyr at en formel henviser til noe som ikke finnes, type =A5+A8, og så slette rad 8.

Hvis dette seriøst gjelder fire ark, kan du ikke bare ha en ANTALL.HVIS i hvert av dem og summere?

Beste hilsen Harald
  • 0


0 bruker(e) leser denne tråden

0 medlemmer, 0 gjester, 0 skjulte brukere