Jump to content
Sign in to follow this  
aeshj

netcom 3g og ubuntu (server?)

Recommended Posts

hei

 

har for øyeblikket bare tilgang på mobilt bredbånd der jeg bor. jeg trenger en løsning der jeg deler usb modemet med flere pc'r.

tenkte litt på ubuntu, vanlig eller server, på en stasjonær pc uten skjerm ( har ingen ledigeskjermer).

 

må være lett og koble til og fra over lokalnettet for å slippe å koble skjerm på.

 

noen idéer?

Share this post


Link to post

You're in luck, har akkurat satt opp NetCom Connect på min egen server. Installer en ønsket distro så kan jeg guide deg igjennom en relativ enkel setup (distroen må iallefall ha kernel 2.6.23+, pppd, dnsmasq og iptables).

Share this post


Link to post

Aktivere modem

 

Først sjekk at modemet er funnet, hvis /dev/ttyUSB0 og /dev/ttyUSB1 eksiterer fungerer nok modemet (dobbeltsjekk med dmesg). Hvis ttyUSB* ikke eksisterer kan det hende kernelen har problemer med å finne modemet, dette grunnet USB/CDROM/MODEM komboen. Dette løses enkelt med et lite program og en udev regel.

 

kompiler huaweiAktBbo (krever gcc, installer build-essential eller lignende)

wget http://www.kanoistika.sk/bobovsky/archiv/umts/huaweiAktBbo.c
cc huaweiAktBbo.c -lusb -o huaweiAktBbo
cp huaweiAktBbo /sbin/

 

Så legg til følgende udevregel:

 

nano /etc/udev/rules.d/50-huawei-e220.rules

SUBSYSTEM=="usb", SYSFS{idProduct}=="1003", SYSFS{idVendor}=="12d1", RUN+="/sbin/huaweiAktBbo"
SUBSYSTEM=="usb", SYSFS{idProduct}=="1003", SYSFS{idVendor}=="12d1", RUN+="/bin/sleep 5"
SUBSYSTEM=="usb", SYSFS{idProduct}=="1003", SYSFS{idVendor}=="12d1", RUN+="/sbin/modprobe usbserial vendor=0x12d1 product=0x1003"

 

Ta ut modemet og restart udev. Modemet skal nå dukke opp i /dev som ttyUSB0 og ttyUSB1 når du kobler det til.

 

Sette opp PPPD

 

Merk at man også kan bruke wvdial, jeg har ingen erfaring med det programmet, og pppd er default i alle distroer. Alle kommandoer må gjøres som root, enten logg in som root (sudo su -) eller legg til sudo foran hver kommando. Anbefaler copy & paste ;)

 

nano /sbin/netcom-chat.sh

#!/bin/sh

# call the preparation chat script (with pin and if this fails without pin)
/usr/sbin/chat -V -f /etc/chatscripts/netcom-prep || /usr/sbin/chat -V -f /etc/chatscripts/netcom-prep-nopin
# wait to switch between GPRS/UMTS
sleep 20
# the final chat script:
/usr/sbin/chat -V -f /etc/chatscripts/netcom

chmod 755 /sbin/netcom-chat.sh

 

nano /etc/chatscripts/netcom (lag mappen chatscripts hvis den ikke ekisterer)

ABORT BUSY
ABORT 'NO CARRIER'
ABORT ERROR
REPORT CONNECT
TIMEOUT 10
SAY "Calling ONE\n"
TIMEOUT 60
"" "ATD*99***1#"
CONNECT \c

 

nano /etc/chatscripts/netcom-prep

ABORT BUSY
ABORT ERROR
ABORT 'NO CARRIER'
REPORT CONNECT
TIMEOUT 10
"" "ATZ"
# replace XXXX with your PIN:
OK "AT+CPIN=XXXX"
OK "ATE1V1&D2&C1S0=0+IFC=2,2"
OK "AT+IPR=115200"
OK "ATE1"
SAY "\nWaiting 20 Seconds to switch between UMTS/GPRS ...\n"

Bytt ut XXXX med din pinkode.

 

nano /etc/chatscripts/netcom-prep-nopin

ABORT BUSY
ABORT ERROR
ABORT 'NO CARRIER'
REPORT CONNECT
TIMEOUT 10
"" "ATZ"
OK "ATE1V1&D2&C1S0=0+IFC=2,2"
OK "AT+IPR=115200"
OK "ATE1"
SAY "\nWaiting 20 Seconds to switch between UMTS/GPRS ...\n"

 

nano /etc/ppp/peers/netcom (opprett mappen(e) hvis de(n) ikke eksisterer)

/dev/ttyUSB0
460800
idle 7200
lock
crtscts
modem
noauth
# dns, routing
usepeerdns
replacedefaultroute
defaultroute
noipdefault
# avoid compression:
noccp
nobsdcomp
novj
# usually doesnt matter for GPRS/UMTS connections:
user "web"
password ""
# connect script
connect "/usr/sbin/netcom-chat.sh"
# t-mobile specific?
ipcp-restart 8
ipcp-max-configure 50
ipcp-accept-local
ipcp-accept-remote

 

nano /etc/resolv.conf

nameserver 212.169.123.67
nameserver 212.45.188.254

 

Du kan nå teste at alt fungerer med å kjøre 'pppd call netcom'. Vi tar deling av nettet når du har fått modemet opp å gå.

Share this post


Link to post
få se output av 'dmesg' og 'pppd nodetach call netcom'.

 

 

viste ikke hvor mye du trengte så jeg tok ALT :p

 

 

dmesg

[ 0.000000] Initializing cgroup subsys cpuset

[ 0.000000] Initializing cgroup subsys cpu

[ 0.000000] Linux version 2.6.27-7-server (buildd@rothera) (gcc version 4.3.2 (Ubuntu 4.3.2-1ubuntu10) ) #1 SMP Fri Oct 24 07:37:55 UTC 2008 (Ubuntu 2.6.27-7.14-server)

[ 0.000000] BIOS-provided physical RAM map:

[ 0.000000] BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)

[ 0.000000] BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)

[ 0.000000] BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)

[ 0.000000] BIOS-e820: 0000000000100000 - 000000001fff0000 (usable)

[ 0.000000] BIOS-e820: 000000001fff0000 - 000000001fff3000 (ACPI NVS)

[ 0.000000] BIOS-e820: 000000001fff3000 - 0000000020000000 (ACPI data)

[ 0.000000] BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)

[ 0.000000] BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)

[ 0.000000] BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)

[ 0.000000] last_pfn = 0x1fff0 max_arch_pfn = 0x1000000

[ 0.000000] kernel direct mapping tables up to 1fff0000 @ 7000-d000

[ 0.000000] RAMDISK: 1f838000 - 1ffdfa0b

[ 0.000000] DMI 2.3 present.

[ 0.000000] ACPI: RSDP 000F6470, 0014 (r0 GBT )

[ 0.000000] ACPI: RSDT 1FFF3000, 002C (r1 GBT AWRDACPI 42302E31 AWRD 1010101)

[ 0.000000] ACPI: FACP 1FFF3040, 0074 (r1 GBT AWRDACPI 42302E31 AWRD 1010101)

[ 0.000000] ACPI: DSDT 1FFF30C0, 379A (r1 GBT AWRDACPI 1000 MSFT 100000C)

[ 0.000000] ACPI: FACS 1FFF0000, 0040

[ 0.000000] ACPI: APIC 1FFF6880, 005A (r1 GBT AWRDACPI 42302E31 AWRD 1010101)

[ 0.000000] 0MB HIGHMEM available.

[ 0.000000] 511MB LOWMEM available.

[ 0.000000] mapped low ram: 0 - 1fff0000

[ 0.000000] low ram: 00000000 - 1fff0000

[ 0.000000] bootmap 00002000 - 00006000

[ 0.000000] (9 early reservations) ==> bootmem [0000000000 - 001fff0000]

[ 0.000000] #0 [0000000000 - 0000001000] BIOS data page ==> [0000000000 - 0000001000]

[ 0.000000] #1 [0000001000 - 0000002000] EX TRAMPOLINE ==> [0000001000 - 0000002000]

[ 0.000000] #2 [0000006000 - 0000007000] TRAMPOLINE ==> [0000006000 - 0000007000]

[ 0.000000] #3 [0000100000 - 00005e8220] TEXT DATA BSS ==> [0000100000 - 00005e8220]

[ 0.000000] #4 [001f838000 - 001ffdfa0b] RAMDISK ==> [001f838000 - 001ffdfa0b]

[ 0.000000] #5 [00005e9000 - 00005f1000] INIT_PG_TABLE ==> [00005e9000 - 00005f1000]

[ 0.000000] #6 [000009fc00 - 0000100000] BIOS reserved ==> [000009fc00 - 0000100000]

[ 0.000000] #7 [0000007000 - 000000a000] PGTABLE ==> [0000007000 - 000000a000]

[ 0.000000] #8 [0000002000 - 0000006000] BOOTMAP ==> [0000002000 - 0000006000]

[ 0.000000] found SMP MP-table at [c00f4b90] 000f4b90

[ 0.000000] Zone PFN ranges:

[ 0.000000] DMA 0x00000000 -> 0x00001000

[ 0.000000] Normal 0x00001000 -> 0x0001fff0

[ 0.000000] HighMem 0x0001fff0 -> 0x0001fff0

[ 0.000000] Movable zone start PFN for each node

[ 0.000000] early_node_map[2] active PFN ranges

[ 0.000000] 0: 0x00000000 -> 0x0000009f

[ 0.000000] 0: 0x00000100 -> 0x0001fff0

[ 0.000000] On node 0 totalpages: 130959

[ 0.000000] free_area_init_node: node 0, pgdat c049eb00, node_mem_map c1000000

[ 0.000000] DMA zone: 3963 pages, LIFO batch:0

[ 0.000000] Normal zone: 125844 pages, LIFO batch:31

[ 0.000000] ACPI: PM-Timer IO Port: 0x4008

[ 0.000000] ACPI: Local APIC address 0xfee00000

[ 0.000000] ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)

[ 0.000000] ACPI: LAPIC_NMI (acpi_id[0x00] dfl dfl lint[0x1])

[ 0.000000] ACPI: IOAPIC (id[0x02] address[0xfec00000] gsi_base[0])

[ 0.000000] IOAPIC[0]: apic_id 2, version 3, address 0xfec00000, GSI 0-23

[ 0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)

[ 0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 low level)

[ 0.000000] ACPI: IRQ0 used by override.

[ 0.000000] ACPI: IRQ2 used by override.

[ 0.000000] ACPI: IRQ9 used by override.

[ 0.000000] Enabling APIC mode: Flat. Using 1 I/O APICs

[ 0.000000] Using ACPI (MADT) for SMP configuration information

[ 0.000000] SMP: Allowing 1 CPUs, 0 hotplug CPUs

[ 0.000000] mapped APIC to ffffb000 (fee00000)

[ 0.000000] mapped IOAPIC to ffffa000 (fec00000)

[ 0.000000] PM: Registered nosave memory: 000000000009f000 - 00000000000a0000

[ 0.000000] PM: Registered nosave memory: 00000000000a0000 - 00000000000f0000

[ 0.000000] PM: Registered nosave memory: 00000000000f0000 - 0000000000100000

[ 0.000000] Allocating PCI resources starting at 30000000 (gap: 20000000:dec00000)

[ 0.000000] PERCPU: Allocating 45852 bytes of per cpu data

[ 0.000000] NR_CPUS: 64, nr_cpu_ids: 1, nr_node_ids 1

[ 0.000000] Built 1 zonelists in Zone order, mobility grouping on. Total pages: 129807

[ 0.000000] Kernel command line: root=UUID=5d2650c8-3edf-453d-9435-13d9f7f60379 ro quiet splash

[ 0.000000] Enabling fast FPU save and restore... done.

[ 0.000000] Enabling unmasked SIMD FPU exception support... done.

[ 0.000000] Initializing CPU#0

[ 0.000000] PID hash table entries: 2048 (order: 11, 8192 bytes)

[ 0.000000] TSC: PIT calibration confirmed by PMTIMER.

[ 0.000000] TSC: using PIT calibration value

[ 0.000000] Detected 1832.685 MHz processor.

[ 0.010000] Console: colour VGA+ 80x25

[ 0.010000] console [tty0] enabled

[ 0.010000] Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)

[ 0.010000] Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)

[ 0.010000] Memory: 505612k/524224k available (2628k kernel code, 18004k reserved, 1201k data, 436k init, 0k highmem)

[ 0.010000] virtual kernel memory layout:

[ 0.010000] fixmap : 0xffc78000 - 0xfffff000 (3612 kB)

[ 0.010000] pkmap : 0xff800000 - 0xffa00000 (2048 kB)

[ 0.010000] vmalloc : 0xe0800000 - 0xff7fe000 ( 495 MB)

[ 0.010000] lowmem : 0xc0000000 - 0xdfff0000 ( 511 MB)

[ 0.010000] .init : 0xc04c3000 - 0xc0530000 ( 436 kB)

[ 0.010000] .data : 0xc0391026 - 0xc04bd800 (1201 kB)

[ 0.010000] .text : 0xc0100000 - 0xc0391026 (2628 kB)

[ 0.010000] Checking if this processor honours the WP bit even in supervisor mode...Ok.

[ 0.010000] CPA: page pool initialized 1 of 1 pages preallocated

[ 0.010000] SLUB: Genslabs=12, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1

[ 0.010015] Calibrating delay loop (skipped), value calculated using timer frequency.. 3665.37 BogoMIPS (lpj=18326850)

[ 0.010044] Security Framework initialized

[ 0.010054] SELinux: Disabled at boot.

[ 0.010090] AppArmor: AppArmor initialized

[ 0.010102] Mount-cache hash table entries: 512

[ 0.010326] Initializing cgroup subsys ns

[ 0.010333] Initializing cgroup subsys cpuacct

[ 0.010336] Initializing cgroup subsys memory

[ 0.010356] CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)

[ 0.010360] CPU: L2 Cache: 512K (64 bytes/line)

[ 0.010378] Checking 'hlt' instruction... OK.

[ 0.050363] SMP alternatives: switching to UP code

[ 0.057038] Freeing SMP alternatives: 11k freed

[ 0.057045] ACPI: Core revision 20080609

[ 0.059276] ACPI: Checking initramfs for custom DSDT

[ 0.411023] ENABLING IO-APIC IRQs

[ 0.411338] ..TIMER: vector=0x31 apic1=0 pin1=2 apic2=-1 pin2=-1

[ 0.516663] CPU0: AMD Athlon XP 2500+ stepping 00

[ 0.520000] Brought up 1 CPUs

[ 0.520000] Total of 1 processors activated (3665.37 BogoMIPS).

[ 0.520000] CPU0 attaching sched-domain:

[ 0.520000] domain 0: span 0 level CPU

[ 0.520000] groups: 0

[ 0.520000] net_namespace: 840 bytes

[ 0.520000] Booting paravirtualized kernel on bare hardware

[ 0.520000] Time: 21:09:47 Date: 11/13/08

[ 0.520000] NET: Registered protocol family 16

[ 0.520000] EISA bus registered

[ 0.520000] ACPI: bus type pci registered

[ 0.520000] PCI: PCI BIOS revision 2.10 entry at 0xfa240, last bus=1

[ 0.520000] PCI: Using configuration type 1 for base access

[ 0.520948] ACPI: EC: Look up EC in DSDT

[ 0.527938] ACPI: Interpreter enabled

[ 0.527949] ACPI: (supports S0 S1 S4 S5)

[ 0.527974] ACPI: Using IOAPIC for interrupt routing

[ 0.535295] ACPI: PCI Root Bridge [PCI0] (0000:00)

[ 0.535400] PCI: 0000:00:00.0 reg 10 32bit mmio: [d0000000, d7ffffff]

[ 0.535469] pci 0000:00:01.0: supports D1

[ 0.535521] PCI: 0000:00:10.0 reg 20 io port: [d000, d01f]

[ 0.535541] pci 0000:00:10.0: supports D1

[ 0.535543] pci 0000:00:10.0: supports D2

[ 0.535546] pci 0000:00:10.0: PME# supported from D0 D1 D2 D3hot D3cold

[ 0.535551] pci 0000:00:10.0: PME# disabled

[ 0.535589] PCI: 0000:00:10.1 reg 20 io port: [d400, d41f]

[ 0.535608] pci 0000:00:10.1: supports D1

[ 0.535610] pci 0000:00:10.1: supports D2

[ 0.535613] pci 0000:00:10.1: PME# supported from D0 D1 D2 D3hot D3cold

[ 0.535617] pci 0000:00:10.1: PME# disabled

[ 0.535655] PCI: 0000:00:10.2 reg 20 io port: [d800, d81f]

[ 0.535674] pci 0000:00:10.2: supports D1

[ 0.535676] pci 0000:00:10.2: supports D2

[ 0.535678] pci 0000:00:10.2: PME# supported from D0 D1 D2 D3hot D3cold

[ 0.535683] pci 0000:00:10.2: PME# disabled

[ 0.535707] PCI: 0000:00:10.3 reg 10 32bit mmio: [ea006000, ea0060ff]

[ 0.535740] pci 0000:00:10.3: supports D1

[ 0.535742] pci 0000:00:10.3: supports D2

[ 0.535744] pci 0000:00:10.3: PME# supported from D0 D1 D2 D3hot D3cold

[ 0.535749] pci 0000:00:10.3: PME# disabled

[ 0.535808] HPET not enabled in BIOS. You might try hpet=force boot option

[ 0.535817] pci 0000:00:11.0: quirk: region 4000-407f claimed by vt8235 PM

[ 0.535822] pci 0000:00:11.0: quirk: region 5000-500f claimed by vt8235 SMB

[ 0.535867] PCI: 0000:00:11.1 reg 20 io port: [dc00, dc0f]

[ 0.535914] PCI: 0000:00:11.5 reg 10 io port: [e000, e0ff]

[ 0.535949] pci 0000:00:11.5: supports D1

[ 0.535951] pci 0000:00:11.5: supports D2

[ 0.535978] PCI: 0000:00:13.0 reg 10 io port: [e400, e4ff]

[ 0.535985] PCI: 0000:00:13.0 reg 14 32bit mmio: [ea004000, ea0040ff]

[ 0.536015] pci 0000:00:13.0: supports D1

[ 0.536017] pci 0000:00:13.0: supports D2

[ 0.536020] pci 0000:00:13.0: PME# supported from D1 D2 D3hot D3cold

[ 0.536025] pci 0000:00:13.0: PME# disabled

[ 0.536050] PCI: 0000:00:14.0 reg 10 32bit mmio: [ea005000, ea0057ff]

[ 0.536056] PCI: 0000:00:14.0 reg 14 32bit mmio: [ea000000, ea003fff]

[ 0.536088] pci 0000:00:14.0: supports D1

[ 0.536090] pci 0000:00:14.0: supports D2

[ 0.536092] pci 0000:00:14.0: PME# supported from D0 D1 D2 D3hot

[ 0.536097] pci 0000:00:14.0: PME# disabled

[ 0.536138] PCI: 0000:01:00.0 reg 10 32bit mmio: [d8000000, dfffffff]

[ 0.536144] PCI: 0000:01:00.0 reg 14 io port: [c000, c0ff]

[ 0.536150] PCI: 0000:01:00.0 reg 18 32bit mmio: [e9000000, e900ffff]

[ 0.536164] PCI: 0000:01:00.0 reg 30 32bit mmio: [0, 1ffff]

[ 0.536178] pci 0000:01:00.0: supports D1

[ 0.536180] pci 0000:01:00.0: supports D2

[ 0.536200] PCI: 0000:01:00.1 reg 10 32bit mmio: [e0000000, e7ffffff]

[ 0.536206] PCI: 0000:01:00.1 reg 14 32bit mmio: [e9010000, e901ffff]

[ 0.536231] pci 0000:01:00.1: supports D1

[ 0.536233] pci 0000:01:00.1: supports D2

[ 0.536266] PCI: bridge 0000:00:01.0 io port: [c000, cfff]

[ 0.536271] PCI: bridge 0000:00:01.0 32bit mmio: [e8000000, e9ffffff]

[ 0.536275] PCI: bridge 0000:00:01.0 32bit mmio pref: [d8000000, e7ffffff]

[ 0.536283] bus 00 -> node 0

[ 0.536292] ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]

[ 0.561235] ACPI: PCI Interrupt Link [LNKA] (IRQs 1 3 4 *5 6 7 10 11 12 14 15)

[ 0.561482] ACPI: PCI Interrupt Link [LNKB] (IRQs 1 3 4 5 6 7 10 *11 12 14 15)

[ 0.561730] ACPI: PCI Interrupt Link [LNKC] (IRQs 1 3 4 5 6 7 10 *11 12 14 15)

[ 0.561977] ACPI: PCI Interrupt Link [LNKD] (IRQs 1 3 4 *5 6 7 10 11 12 14 15)

[ 0.562217] ACPI: PCI Interrupt Link [ALKA] (IRQs 20) *0

[ 0.562454] ACPI: PCI Interrupt Link [ALKB] (IRQs 21) *0

[ 0.562718] ACPI: PCI Interrupt Link [ALKC] (IRQs 22) *0

[ 0.562958] ACPI: PCI Interrupt Link [ALKD] (IRQs 23) *0

[ 0.563194] Linux Plug and Play Support v0.97 © Adam Belay

[ 0.563250] pnp: PnP ACPI init

[ 0.563260] ACPI: bus type pnp registered

[ 0.568888] pnp: PnP ACPI: found 15 devices

[ 0.568891] ACPI: ACPI bus type pnp unregistered

[ 0.568896] PnPBIOS: Disabled by ACPI PNP

[ 0.569463] PCI: Using ACPI for IRQ routing

[ 0.569610] NET: Registered protocol family 8

[ 0.569610] NET: Registered protocol family 20

[ 0.569610] NetLabel: Initializing

[ 0.569610] NetLabel: domain hash size = 128

[ 0.569610] NetLabel: protocols = UNLABELED CIPSOv4

[ 0.569610] NetLabel: unlabeled traffic allowed by default

[ 0.570167] tracer: 772 pages allocated for 65536 entries of 48 bytes

[ 0.570170] actual entries 65620

[ 0.570501] AppArmor: AppArmor Filesystem Enabled

[ 0.570522] ACPI: RTC can wake from S4

[ 0.570581] system 00:02: ioport range 0x4000-0x407f has been reserved

[ 0.570586] system 00:02: ioport range 0x40f0-0x40ff has been reserved

[ 0.570591] system 00:02: ioport range 0x5000-0x500f has been reserved

[ 0.570599] system 00:03: ioport range 0x4d0-0x4d1 has been reserved

[ 0.570603] system 00:03: ioport range 0x290-0x29f has been reserved

[ 0.570606] system 00:03: ioport range 0x800-0x805 has been reserved

[ 0.605974] pci 0000:00:01.0: PCI bridge, secondary bus 0000:01

[ 0.605981] pci 0000:00:01.0: IO window: 0xc000-0xcfff

[ 0.605988] pci 0000:00:01.0: MEM window: 0xe8000000-0xe9ffffff

[ 0.605992] pci 0000:00:01.0: PREFETCH window: 0x000000d8000000-0x000000e7ffffff

[ 0.606010] pci 0000:00:01.0: setting latency timer to 64

[ 0.606015] bus: 00 index 0 io port: [0, ffff]

[ 0.606017] bus: 00 index 1 mmio: [0, ffffffffffffffff]

[ 0.606020] bus: 01 index 0 io port: [c000, cfff]

[ 0.606023] bus: 01 index 1 mmio: [e8000000, e9ffffff]

[ 0.606026] bus: 01 index 2 mmio: [d8000000, e7ffffff]

[ 0.606028] bus: 01 index 3 mmio: [0, 0]

[ 0.606052] NET: Registered protocol family 2

[ 0.606308] IP route cache hash table entries: 4096 (order: 2, 16384 bytes)

[ 0.606622] TCP established hash table entries: 16384 (order: 5, 131072 bytes)

[ 0.606831] TCP bind hash table entries: 16384 (order: 5, 131072 bytes)

[ 0.607039] TCP: Hash tables configured (established 16384 bind 16384)

[ 0.607043] TCP reno registered

[ 0.607132] NET: Registered protocol family 1

[ 0.607288] checking if image is initramfs... it is

[ 1.110057] Switched to high resolution mode on CPU 0

[ 1.361528] Freeing initrd memory: 7838k freed

[ 1.362912] audit: initializing netlink socket (disabled)

[ 1.362941] type=2000 audit(1226610587.360:1): initialized

[ 1.369531] HugeTLB registered 2 MB page size, pre-allocated 0 pages

[ 1.373189] VFS: Disk quotas dquot_6.5.1

[ 1.373323] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)

[ 1.373480] msgmni has been set to 1003

[ 1.373668] io scheduler noop registered

[ 1.373672] io scheduler anticipatory registered

[ 1.373675] io scheduler deadline registered (default)

[ 1.373690] io scheduler cfq registered

[ 1.373707] PCI: VIA PCI bridge detected.Disabling DAC.

[ 1.373780] pci 0000:01:00.0: Boot video device

[ 1.374296] isapnp: Scanning for PnP cards...

[ 1.730672] isapnp: No Plug & Play device found

[ 1.792299] Serial: 8250/16550 driver4 ports, IRQ sharing enabled

[ 1.792473] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A

[ 1.792662] serial8250: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A

[ 1.793572] 00:09: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A

[ 1.793999] 00:0a: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A

[ 1.796894] brd: module loaded

[ 1.797011] input: Macintosh mouse button emulation as /devices/virtual/input/input0

[ 1.797326] PNP: No PS/2 controller found. Probing ports directly.

[ 1.797814] serio: i8042 KBD port at 0x60,0x64 irq 1

[ 1.797823] serio: i8042 AUX port at 0x60,0x64 irq 12

[ 1.798623] mice: PS/2 mouse device common for all mice

[ 1.798850] rtc_cmos 00:05: rtc core: registered rtc_cmos as rtc0

[ 1.798886] rtc0: alarms up to one year, y3k

[ 1.799063] EISA: Probing bus 0 at eisa.0

[ 1.799091] Cannot allocate resource for EISA slot 4

[ 1.799095] Cannot allocate resource for EISA slot 5

[ 1.799110] EISA: Detected 0 cards.

[ 1.799115] cpuidle: using governor ladder

[ 1.799118] cpuidle: using governor menu

[ 1.799813] TCP cubic registered

[ 1.799856] Using IPI No-Shortcut mode

[ 1.800206] registered taskstats version 1

[ 1.800354] Magic number: 0:851:196

[ 1.800459] tty ttys8: hash matches

[ 1.800479] tty ttypb: hash matches

[ 1.800686] rtc_cmos 00:05: setting system clock to 2008-11-13 21:09:48 UTC (1226610588)

[ 1.800690] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found

[ 1.800693] EDD information not available.

[ 1.801394] Freeing unused kernel memory: 436k freed

[ 1.801527] Write protecting the kernel text: 2632k

[ 1.801582] Write protecting the kernel read-only data: 956k

[ 1.933687] fuse init (API version 7.9)

[ 1.962311] processor ACPI0007:00: registered as cooling_device0

[ 1.962319] ACPI: Processor [CPU0] (supports 2 throttling states)

[ 2.597075] usbcore: registered new interface driver usbfs

[ 2.597116] usbcore: registered new interface driver hub

[ 2.597175] usbcore: registered new device driver usb

[ 2.614265] USB Universal Host Controller Interface driver v3.0

[ 2.614769] ACPI: PCI Interrupt Link [ALKB] BIOS reported IRQ 0, using IRQ 21

[ 2.614774] ACPI: PCI Interrupt Link [ALKB] enabled at IRQ 21

[ 2.614788] uhci_hcd 0000:00:10.0: PCI INT A -> Link[ALKB] -> GSI 21 (level, low) -> IRQ 21

[ 2.614803] uhci_hcd 0000:00:10.0: UHCI Host Controller

[ 2.614887] uhci_hcd 0000:00:10.0: new USB bus registered, assigned bus number 1

[ 2.614931] uhci_hcd 0000:00:10.0: irq 21, io base 0x0000d000

[ 2.615221] usb usb1: configuration #1 chosen from 1 choice

[ 2.615258] hub 1-0:1.0: USB hub found

[ 2.615274] hub 1-0:1.0: 2 ports detected

[ 2.648105] No dock devices found.

[ 2.720693] SCSI subsystem initialized

[ 2.725415] 8139cp: 10/100 PCI Ethernet driver v1.3 (Mar 22, 2004)

[ 2.807697] libata version 3.00 loaded.

[ 2.830507] uhci_hcd 0000:00:10.1: PCI INT B -> Link[ALKB] -> GSI 21 (level, low) -> IRQ 21

[ 2.830528] uhci_hcd 0000:00:10.1: UHCI Host Controller

[ 2.830569] uhci_hcd 0000:00:10.1: new USB bus registered, assigned bus number 2

[ 2.830599] uhci_hcd 0000:00:10.1: irq 21, io base 0x0000d400

[ 2.830745] usb usb2: configuration #1 chosen from 1 choice

[ 2.830783] hub 2-0:1.0: USB hub found

[ 2.830798] hub 2-0:1.0: 2 ports detected

[ 2.950269] usb 1-1: new low speed USB device using uhci_hcd and address 2

[ 3.050484] uhci_hcd 0000:00:10.2: PCI INT C -> Link[ALKB] -> GSI 21 (level, low) -> IRQ 21

[ 3.050502] uhci_hcd 0000:00:10.2: UHCI Host Controller

[ 3.050557] uhci_hcd 0000:00:10.2: new USB bus registered, assigned bus number 3

[ 3.050586] uhci_hcd 0000:00:10.2: irq 21, io base 0x0000d800

[ 3.050735] usb usb3: configuration #1 chosen from 1 choice

[ 3.050772] hub 3-0:1.0: USB hub found

[ 3.050789] hub 3-0:1.0: 2 ports detected

[ 3.134200] usb 1-1: configuration #1 chosen from 1 choice

[ 3.270549] ehci_hcd 0000:00:10.3: PCI INT D -> Link[ALKB] -> GSI 21 (level, low) -> IRQ 21

[ 3.270580] ehci_hcd 0000:00:10.3: EHCI Host Controller

[ 3.270628] ehci_hcd 0000:00:10.3: new USB bus registered, assigned bus number 4

[ 3.270686] ehci_hcd 0000:00:10.3: irq 21, io mem 0xea006000

[ 3.290078] ehci_hcd 0000:00:10.3: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004

[ 3.290397] usb usb4: configuration #1 chosen from 1 choice

[ 3.290440] hub 4-0:1.0: USB hub found

[ 3.290461] hub 4-0:1.0: 6 ports detected

[ 3.290502] usb 1-1: USB disconnect, address 2

[ 3.510475] pata_via 0000:00:11.1: version 0.3.3

[ 3.510925] ACPI: PCI Interrupt Link [ALKA] BIOS reported IRQ 0, using IRQ 20

[ 3.510929] ACPI: PCI Interrupt Link [ALKA] enabled at IRQ 20

[ 3.510942] pata_via 0000:00:11.1: PCI INT A -> Link[ALKA] -> GSI 20 (level, low) -> IRQ 20

[ 3.511191] scsi0 : pata_via

[ 3.511395] scsi1 : pata_via

[ 3.514483] ata1: PATA max UDMA/133 cmd 0x1f0 ctl 0x3f6 bmdma 0xdc00 irq 14

[ 3.514488] ata2: PATA max UDMA/133 cmd 0x170 ctl 0x376 bmdma 0xdc08 irq 15

[ 3.690481] ata1.00: ATA-7: SAMSUNG SP2014N, VC100-41, max UDMA/100

[ 3.690488] ata1.00: 390721968 sectors, multi 16: LBA48

[ 3.750317] ata1.00: configured for UDMA/100

[ 3.850021] usb 1-1: new low speed USB device using uhci_hcd and address 3

[ 3.910529] ata2.00: ATAPI: SONY CD-RW CRX300E, KYS2, max UDMA/33

[ 3.910979] ata2.00: configured for UDMA/33

[ 3.911147] scsi 0:0:0:0: Direct-Access ATA SAMSUNG SP2014N VC10 PQ: 0 ANSI: 5

[ 3.912437] scsi 1:0:0:0: CD-ROM SONY CD-RW CRX300E KYS2 PQ: 0 ANSI: 5

[ 3.913657] 8139cp 0000:00:13.0: This (id 10ec:8139 rev 10) is not an 8139C+ compatible chip

[ 3.913714] 8139cp 0000:00:13.0: Try the "8139too" driver instead.

[ 3.917675] ohci1394 0000:00:14.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17

[ 3.967943] ohci1394: fw-host0: OHCI-1394 1.1 (PCI): IRQ=[17] MMIO=[ea005000-ea0057ff] Max Packet=[2048] IR/IT contexts=[4/8]

[ 3.968116] 8139too Fast Ethernet driver 0.9.28

[ 3.970261] 8139too 0000:00:13.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18

[ 3.970885] eth0: RealTek RTL8139 at 0xe400, 00:0d:61:02:39:b7, IRQ 18

[ 3.970889] eth0: Identified 8139 chip type 'RTL-8100B/8139D'

[ 4.044085] usb 1-1: configuration #1 chosen from 1 choice

[ 4.062269] scsi 0:0:0:0: Attached scsi generic sg0 type 0

[ 4.062337] scsi 1:0:0:0: Attached scsi generic sg1 type 5

[ 4.104813] usbcore: registered new interface driver hiddev

[ 4.119325] input: Logitech Logitech USB Keyboard as /devices/pci0000:00/0000:00:10.0/usb1/1-1/1-1:1.0/input/input1

[ 4.131317] Driver 'sd' needs updating - please use bus_type methods

[ 4.131516] sd 0:0:0:0: [sda] 390721968 512-byte hardware sectors (200050 MB)

[ 4.131550] sd 0:0:0:0: [sda] Write Protect is off

[ 4.131554] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00

[ 4.131605] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA

[ 4.131723] sd 0:0:0:0: [sda] 390721968 512-byte hardware sectors (200050 MB)

[ 4.131751] sd 0:0:0:0: [sda] Write Protect is off

[ 4.131754] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00

[ 4.131802] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA

[ 4.131809] sda: sda1 sda2 <<6>input,hidraw0: USB HID v1.10 Keyboard [Logitech Logitech USB Keyboard] on usb-0000:00:10.0-1

[ 4.140661] Driver 'sr' needs updating - please use bus_type methods

[ 4.154297] sda5 sda6 >

[ 4.154795] sd 0:0:0:0: [sda] Attached SCSI disk

[ 4.163693] sr0: scsi3-mmc drive: 0x/48x writer cd/rw xa/form2 cdda tray

[ 4.163703] Uniform CD-ROM driver Revision: 3.20

[ 4.163903] sr 1:0:0:0: Attached scsi CD-ROM sr0

[ 4.171920] input: Logitech Logitech USB Keyboard as /devices/pci0000:00/0000:00:10.0/usb1/1-1/1-1:1.1/input/input2

[ 4.200326] input,hidraw1: USB HID v1.10 Device [Logitech Logitech USB Keyboard] on usb-0000:00:10.0-1

[ 4.200362] usbcore: registered new interface driver usbhid

[ 4.200368] usbhid: v2.6:USB HID core driver

[ 4.420504] PM: Starting manual resume from disk

[ 4.420510] PM: Resume from partition 8:6

[ 4.420512] PM: Checking hibernation image.

[ 4.420729] PM: Resume from disk failed.

[ 4.477631] kjournald starting. Commit interval 5 seconds

[ 4.477658] EXT3-fs: mounted filesystem with ordered data mode.

[ 5.290340] ieee1394: Host added: ID:BUS[0-00:1023] GUID[000d61000000e8b9]

[ 6.510069] udevd version 124 started

[ 7.275621] Linux agpgart interface v0.103

[ 7.292940] pci_hotplug: PCI Hot Plug PCI Core version: 0.5

[ 7.325551] agpgart: Detected VIA KM400/KM400A chipset

[ 7.334117] agpgart-via 0000:00:00.0: AGP aperture is 128M @ 0xd0000000

[ 7.362229] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4

[ 7.817318] input: Power Button (FF) as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input3

[ 7.860062] ACPI: Power Button (FF) [PWRF]

[ 7.860222] input: Power Button (CM) as /devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input4

[ 7.863998] irda_init()

[ 7.864022] NET: Registered protocol family 23

[ 7.900098] ACPI: Power Button (CM) [PWRB]

[ 8.059375] ACPI: PCI Interrupt Link [ALKC] BIOS reported IRQ 0, using IRQ 22

[ 8.059382] ACPI: PCI Interrupt Link [ALKC] enabled at IRQ 22

[ 8.059394] VIA 82xx Audio 0000:00:11.5: PCI INT C -> Link[ALKC] -> GSI 22 (level, low) -> IRQ 22

[ 8.059753] VIA 82xx Audio 0000:00:11.5: setting latency timer to 64

[ 8.600614] parport_pc 00:0b: reported by Plug and Play ACPI

[ 8.600662] parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE]

[ 9.919512] input: PC Speaker as /devices/platform/pcspkr/input/input5

[ 13.285426] loop: module loaded

[ 13.311868] lp0: using parport0 (interrupt-driven).

[ 13.576956] Adding 1895596k swap on /dev/sda6. Priority:-1 extents:1 across:1895596k

[ 14.017303] EXT3 FS on sda1, internal journal

[ 14.934860] ip_tables: © 2000-2006 Netfilter Core Team

[ 53.140016] usb 3-2: new full speed USB device using uhci_hcd and address 2

[ 53.307261] usb 3-2: configuration #1 chosen from 1 choice

[ 53.382635] usbcore: registered new interface driver libusual

[ 53.410534] Initializing USB Mass Storage driver...

[ 53.412556] scsi2 : SCSI emulation for USB Mass Storage devices

[ 53.412753] usbcore: registered new interface driver usb-storage

[ 53.412759] USB Mass Storage support registered.

[ 53.412779] usb-storage: device found at 2

[ 53.412782] usb-storage: waiting for device to settle before scanning

[ 53.540089] usb 3-2: USB disconnect, address 2

[ 54.320015] usb 3-2: new full speed USB device using uhci_hcd and address 3

[ 54.488048] usb 3-2: configuration #1 chosen from 1 choice

[ 54.490121] usb-storage: probe of 3-2:1.0 failed with error -5

[ 54.493459] usb-storage: probe of 3-2:1.1 failed with error -5

[ 54.495839] scsi5 : SCSI emulation for USB Mass Storage devices

[ 54.496215] usb-storage: device found at 3

[ 54.496218] usb-storage: waiting for device to settle before scanning

[ 54.666539] usbcore: registered new interface driver usbserial

[ 54.666568] usbserial: USB Serial support registered for generic

[ 54.666615] usbcore: registered new interface driver usbserial_generic

[ 54.666618] usbserial: USB Serial Driver core

[ 54.684197] usbserial: USB Serial support registered for GSM modem (1-port)

[ 54.684244] option 3-2:1.0: GSM modem (1-port) converter detected

[ 54.684634] usb 3-2: GSM modem (1-port) converter now attached to ttyUSB0

[ 54.684650] option 3-2:1.1: GSM modem (1-port) converter detected

[ 54.684748] usb 3-2: GSM modem (1-port) converter now attached to ttyUSB1

[ 54.684766] usbcore: registered new interface driver option

[ 54.684770] option: USB Driver for GSM modems: v0.7.2

[ 59.491155] usb-storage: device scan complete

[ 59.494124] scsi 5:0:0:0: CD-ROM HUAWEI Mass Storage 2.31 PQ: 0 ANSI: 2

[ 59.521134] sr1: scsi-1 drive

[ 59.521348] sr 5:0:0:0: Attached scsi CD-ROM sr1

[ 59.521600] sr 5:0:0:0: Attached scsi generic sg2 type 5

[ 85.245287] PPP generic driver version 2.4.2

[ 85.321285] NET: Registered protocol family 10

[ 85.321953] lo: Disabled Privacy Extensions

[ 927.000055] usb 3-2: USB disconnect, address 3

[ 927.002058] option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0

[ 927.002087] option 3-2:1.0: device disconnected

[ 927.002460] option1 ttyUSB1: GSM modem (1-port) converter now disconnected from ttyUSB1

[ 927.002477] option 3-2:1.1: device disconnected

[ 1132.330017] usb 3-2: new full speed USB device using uhci_hcd and address 4

[ 1132.497245] usb 3-2: configuration #1 chosen from 1 choice

[ 1132.501052] scsi6 : SCSI emulation for USB Mass Storage devices

[ 1132.501639] usb-storage: device found at 4

[ 1132.501643] usb-storage: waiting for device to settle before scanning

[ 1132.980041] usb 3-2: USB disconnect, address 4

[ 1133.260015] usb 3-2: new full speed USB device using uhci_hcd and address 5

[ 1133.428095] usb 3-2: configuration #1 chosen from 1 choice

[ 1133.430160] usb-storage: probe of 3-2:1.0 failed with error -5

[ 1133.430192] option 3-2:1.0: GSM modem (1-port) converter detected

[ 1133.430585] usb 3-2: GSM modem (1-port) converter now attached to ttyUSB0

[ 1133.433441] usb-storage: probe of 3-2:1.1 failed with error -5

[ 1133.433472] option 3-2:1.1: GSM modem (1-port) converter detected

[ 1133.433715] usb 3-2: GSM modem (1-port) converter now attached to ttyUSB1

[ 1133.436881] scsi9 : SCSI emulation for USB Mass Storage devices

[ 1133.437283] usb-storage: device found at 5

[ 1133.437287] usb-storage: waiting for device to settle before scanning

[ 1138.431195] usb-storage: device scan complete

[ 1138.434159] scsi 9:0:0:0: CD-ROM HUAWEI Mass Storage 2.31 PQ: 0 ANSI: 2

[ 1138.462137] sr1: scsi-1 drive

[ 1138.462347] sr 9:0:0:0: Attached scsi CD-ROM sr1

[ 1138.462596] sr 9:0:0:0: Attached scsi generic sg2 type 5

 

 

 

pppd

sh: /usr/sbin/netcom-chat.sh: not found

Connect script failed

Share this post


Link to post
pppd

sh: /usr/sbin/netcom-chat.sh: not found

Connect script failed

Alt ser bra ut i dmesg, men som du ser over eksisterer ikke /usr/sbin/netcom-chat.sh.

 

EDIT: Min feil :) (sneket seg inn en skrivefeil i "guiden")

 

chmod 755 /usr/sbin/netcom-chat.sh

Edited by olear

Share this post


Link to post
pppd

sh: /usr/sbin/netcom-chat.sh: not found

Connect script failed

Alt ser bra ut i dmesg, men som du ser over eksisterer ikke /usr/sbin/netcom-chat.sh.

 

EDIT: Min feil :) (sneket seg inn en skrivefeil i "guiden")

 

chmod 755 /usr/sbin/netcom-chat.sh

 

har fikset "skrivefeilen", men får samme output.....

Share this post


Link to post
Kjør «ls -l /usr/sbin/netcom-chat.sh», da vil du se om filen finnes og om rettighetene er riktig.

 

-rwxr-xr-x 1 root root 316 2008-11-13 22:20 /usr/sbin/netcom-chat.sh

Edited by aeshj

Share this post


Link to post
Hehe, pppd er konfigurert til å kjøre "/usr/sbin/netcom-chat.sh" mens filen ligger i "/sbin/netcom-chat.sh".

har kopiert filen og chmoddet den i "/usr/sbin/netcom-chat.sh"

 

får samme feilmelding

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...