Jump to content
Sign in to follow this  
fakey

IE rendrer dårlig (position absolute og relative)

Recommended Posts

http://www.fakey.no/beta/

 

Se forskjellene i opera og IE. Ser ut som IE legger inn noen mellomrom og luft her og der.

 

Fant ut at dette trolig skyldes bruken av position: absolute og relative.

 

Hvordan fikse dette?

Edited by banansplitt

Share this post


Link to post
Hmm... Er ikke helt sikker på dette... Men hva er en portfolio side?

6748375[/snapback]

 

En portfolio (portefølje på norsk) er et sted man kan legge ut arbeider. Samle arbeider.

Share this post


Link to post
Hvordan fikse dette?

6748290[/snapback]

Du kan jo prøve å ikke bruke absolut og relative.

Det beste er bare å bruke align (og litt relative).

 

Et annet tips er å ikke bruke absolut og relative inni andre div elementer.

Det har ihvert fall jeg dårlig erfaringer med.

 

I tillegg er det ofte enklere å kode med html 4.01 enn xhtml.

Edited by JonT

Share this post


Link to post
Hvordan fikse dette?

6748290[/snapback]

Du kan jo prøve å ikke bruke absolut og relative.

Det beste er bare å bruke align (og litt relative).

 

Et annet tips er å ikke bruke absolut og relative inni andre div elementer.

Det har ihvert fall jeg dårlig erfaringer med.

 

I tillegg er det ofte enklere å kode med html 4.01 enn xhtml.

6752938[/snapback]

Problemet er at jeg bruker Gilder/Levin metoden for image replacement, og må dermed bruke position. Jeg har fått fikset en del av problemene nå, men det gjenstår fortsatt noen få.

Share this post


Link to post

Hmm.. Da har du jo et problem. Sikker på at du har satt alle margin og padding til 0 (vis de ikke er angitt til noe annet)

 

Kan ikke helt se hvordan du kan løse det.

Du kan jo justere noe de i IE stylesheetet ditt (eller noen andre IE hacker), selv om det ikke er den helt "riktige" måten å gjøre det på.

Edited by JonT

Share this post


Link to post

Prøv å erstatt

h1 span { width:100%; height:100%; background:url(../img/header.jpg) bottom; position:absolute; }

med

h1 span { width:100%; height:100%; background:url(../img/header.jpg); position:absolute; top: 0; left: 0; }

Share this post


Link to post
Prøv å erstatt

h1 span { width:100%; height:100%; background:url(../img/header.jpg) bottom; position:absolute; }

med

h1 span { width:100%; height:100%; background:url(../img/header.jpg); position:absolute; top: 0; left: 0; }

6755277[/snapback]

 

Den vakke helt rett, men med litt fiksing så er headeren også fikset! Tusen takk! :)

 

Eneste som gjenstår er vel egentlig menyen i IE. Den ser helt rar ut :no:

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...