Jump to content
Sign in to follow this  
cmi

vil ha siden min strøken i alle nettlesere

Recommended Posts

Hva må jeg gjøre for og være 100% sikker på dette, folk sier det ikke er ikke er det spøtt vansklig, man må bare kunne det :hrm:

 

Noen som kan hjelpe meg??

Share this post


Link to post

Om folk sier at det ikke er vanskelig så.

 

A) tar de ikke høyde for ALL nettlesere og platformer

B) har en lavere terslek av hva de akseptere som ok.

 

Det er ikke hjerne kirurgi, men det er ikke så lett heller.

 

Jeg har faktisk ingen konkrete råd, for det er så forskjellig ting man må gjøre ved valg av forskjellige teknologier. Forskjellige browsere tolker HTML og CSS forskjellig. Noen liker en ting og andre ikke det andre...en font funker ok på PC men er nesten uleselig på en MAC..osv.

 

Man må takle ett og ett problem om gangen. Sjekke siden opp mot validerings sider og fikse ting en etter en. Noe som fikses vil skape nye problemer osv....helt til alt ser bra ut i alle browsere.

 

Du bør ha IE, Firefox og Oper på maskinen din da. Så du får testa i alle de største browserne.

 

Det eneste som kan garantere en helhetelig visuell likhet på alle platformer er å lage ting i Flash. Men da kan du miste andre muligheter som HTML gir.

 

Så det er ikke en konkret ting å gjøre..utenom å nøste opp probleme når de oppstår. Google rundt etter løsninger og spørre om hjelp når du har konkrete problemer.

 

AKIRA

Share this post


Link to post

Støtte på et problem nå: jeg hadde fått linket det ene bildet mitt (via koder) så skulle jeg linke bilde nr 2, nå funker ikke linkingen til bilde nr 1 lengre, ser noen noe galt med kodene?? (legger med kodene til bilde 1 og 2 :hmm:

 

<tr>
<td>
<table width="739"> 
     <tr>
         <td width='156' class=bakgrunnAktKal rowspan=2 align="center">
             <a href="Fugle bilder/Smaalom (1).jpg" title="stort bilde" rel="lightbox"> <img border="0" src="minitayrbilder/fotoga1.jpg" align="right" style="border: 3px double #FFFFFF"/></a><img border="0" src="minitayrbilder/fotoga1.jpg" align="right" style="border: 3px double #FFFFFF"/></a>

             <td width="73%" bgcolor="#000000">
                  <b class=ingress>Smålom (Gavia arctica)</b> <br><br>
                  Hovet, Buskerud, Norge - 2006</td>
      </tr>
      <tr>
          <td>
               </td>
      </tr>
      <tr>
      <td colspan=2 bgcolor=#ffffff align="center"></td>
      </tr>

	<tr>
		<td width='156' class=bakgrunnAktKal rowspan=2 align="center">
			<a href="Fugle bilder/Smaalom (2).jpg" title="stort bilde" rel="lightbox"> <img border="0" src="minitayrbilder/fotoga2.jpg" align="right" style="border: 3px double #FFFFFF"/></a></a>

		<td width="73%" bgcolor="#000000">
			<b class=ingress>Smålom (Gavia arctica)</b> <br><br>
			Vats, Buskerud, Norge - 2006</td>
	</tr>
	<tr>
		<td>
			 </td>
	</tr>
	<tr>
	<td colspan=2 bgcolor=#ffffff align="center"></td>
	</tr>

 

Noe som ikke stemmer her?? tenker det kansje er noe som krysser hverandre?? så ikke begge bildene vil være linket samtidig...?

 

Edit: fant det ut, finkjemet koden og da merket jeg at den hadde lagt seg 2 ganger på det første bilde

Edited by cmi

Share this post


Link to post

Har testen siden min nå, den funker nice i IE men har noen småfeil i Opera og FF, i Opera er problemene: strekene på siden og galleriet er litt "fucka"

 

Se her: siden min

 

Kan noen hjelpe meg med dette??

 

Tror ikke det er store saken for de med peil.

Share this post


Link to post

Hepp. Når jeg designer sider for så mange browsere som mulig bruker jeg stort sett W3C validators til alt er helt strøkent, og sida ser pen ut i firefox. Laster den så i IE etc og retter ut småtingene som er feil.

 

Stort sett er det IE som synder mot standarer, så lager du en side som er helt korrekt satt opp mht W3C funker den stort sett helt fint i opera/firefox og mange andre. De tingene som ser annerledes ut i IE etter dette er det som oftest enkle 'fixes' for, som du lett finner på nett.

Share this post


Link to post

Fiks:

<p><img src="images/Header%20org.jpg"></p></div><!-- header -->

 

Bytte ut med:

<p><img src="images/Header%20org.jpg" alt="bilde" /></p></div><!-- header -->

Share this post


Link to post

Det hjalp ikke til noen av mine problemer :cry:

 

Er liksom galleriet som er galt i Opera og FireFox.

Bildene åpner seg riktig i Firefox, men ikke Opera og InternetExplorer da de åpner seg til venstre og ikke midt på.

 

Også er det de grå linjene i kantene på siden som ikke går helt ned i noen av sidene i Opera og FireFox.

 

Alt annet funker som det skal i InternetExplorer utenom kun når man trykker på miniatyr bildene så kommer bilde til høyre og ikke midt på, dette som står her vil jeg gjerne få fikset :(

Edited by cmi

Share this post


Link to post

Har fått fikset miniatryr bildene i Opera, FireFox og IE! da er det bare de design strekene i hver kant på alle sidene også at bilde skal åpne seg på midten i Opera og IE, noen som kan hjelpe meg??

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...