Jump to content
Sign in to follow this  
znora

problem med pointer.

Recommended Posts

hei.

Her sitter jeg igjen og prøver å skrive noe enkel vinduskode mot QT APIet.QT APIet.

Alt fungerer egentlig ganske bra. Eneste glitchen er at jeg er java koder primert, og derfor ikke skønner pointers.

Prosjetet er ganske stort fordi jeg implementerer en del frontends/wrappers/annenmanskode. Det som derimot er rellevant kan oppsumeres i disse linkene:

 

 

main kjører en QWidget som kjører OpenGL

 

dette gir compilerroren:

 Undefined symbols:
vtable for GLContent
collect2: Id returned 1 exit status

 

Hvis jeg derimot bytter ut:

//window.h
private:
GLContent gl_box; 

får jeg i linje:

mainLayout->addWidget(gl_box);

feilen: her

 

 

 

QT api docs

 

takk for all hjelp

Share this post


Link to post

problemet forblir et mysterium. Derimot klarte jeg å ommgå det ved "å starte på nytt". Noe tyder på at det er prosjektinnstillningene og ikke koden det er noe galt med.

Kanskje jeg skjønner det når jeg blir stor gutt.

Share this post


Link to post

Vel er du sikker på at pointere er ditt problem?

Du bruker en annen kompilator en det jeg gjøre så feilteksten er nok ikke den samme, men jeg ser ingenting som tyder på pointerfeil. Kompilatorfeil med pointere er somregel veldig lette å fikse med * eller &, men runtime feil er derimot veldig lette å få når man har liten erfaring med pointere.

 

Etter det jeg ser så har du ingen problemer med pointere i kompilatortime

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...