Jump to content
Sign in to follow this  
tha_lode

krøll med video-ut på matrox skjermkort

Recommended Posts

Hei alle.

 

Dette er en forklaring som forhåpentligvis kan hjelpe andre som sliter med samme problem. (har brukt en uke selv på dette nå)

 

Jeg har en stuepc (Shuttle ss51G) med et Matrox g450 skjermkort.

Jeg hadde et merkelig problem hvor bildet "lugget" ca en gang i sekundet. Mao det holdt litt igjen før det fortsatte å flyte.

Det var spesielt merkbart på store bevegelser i bildet.

(Prøvde også Matrox p650 uten at det hjalp)

 

Dette gjaldt bare på videoutgangen. På dataskjerm fløt bildet som en drøm.

 

Sleit litt med å finne ut hva jeg skulle google på for å knekke denne nøtta.

 

Fant til slutt ut dette:

Matrox sine kort har et problem med å spille av video som ikke har samme fps som videostandarden den skal sende ut på. Mao: Er det en amerikansk film med 23.97 fps (NTSC) som skal ut på en europeisk 25 fps (PAL) video standard så holder den igjen et bilde en gang i sekundet for at "bildemengden" skal gå opp med 25 fps.

 

Det er laget en fix for dette som heter divxg400.

http://www.tac.ee/~prr/videoutils/divxg400.html

 

Dette programmet tvinger video som har "nesten" 25 fps til å avspilles i nøyaktig 25 fps.

 

Dette hørtes jo fullkomment ut for meg. Men så viste det seg at det kun virket på noen filmer og ikke alle. Etter ytterligere hodekløing fant jeg at det kun var filmer hvor det kun var streit stereo MP3 lyd at bildet fløt godt. Filmer med AC3 virket fortsatt ikke.

 

Etter mye prøving og feiling oppdaget jeg at ffdshow surret i bakgrunnen hver gang jeg sleit med å få bildet til å flyte. Så, eventyrlysten som jeg er så avinstallerte jeg ffdshow.

 

Vips virket alt som det skulle. Det virker som om ffdshow overstyrer Divxg400 av en eller annen grunn. (Jeg måtte også luke ut DivX codecen også for å slippe å se den irriterende logoen deres nede i høyre hjørne på filmen, men Xvid gjør jo dekoder jobben fullkomment uansett.)

 

God film!

 

ps. (noen søkeord for folk som googler etter svar) choppy video playback, Matrox, 25 fps, Pal, NTSC, DivxG400

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...