Jump to content
Sign in to follow this  
negativecreep

SDL & AALIB

Recommended Posts

Noen som har erfaringer med programmering med SDL+AALIB? Jeg eksporterer SDL_VIDEODRIVER="aalib" variabelen før jeg kjører programmet jeg tester med og det dukker opp en del tegn på skjermen, men absolutt ikke det som skulle ha vært der.

 

Programmet jeg tester med initialiserer SDL til 640x480x32 når jeg kjører den til vanlig (Grafisk modus. Vet ikke hvilken driver den velger som standard, men det er ikke så viktig i denne sammenhengen). Er dette noe jeg må endre på for at det skal fungere med AALIB?

Share this post


Link to post

Hm. Jeg kjører dette over ssh fra jobben nå og når jeg logget inn nå for å sjekke så fungerte det faktisk. Vet ikke hva som har skjedd i mellomtiden men det funker ihvertfall :smile:.

 

Men uansett, takk for svar.

Share this post


Link to post

Hvis folk er interessert så fant jeg ut hva problemet var. Jeg hadde definert en miljøvariabel tidligere som satt aalib oppløsning for høy (prøvde å få i gang ut2003 i ascii :smile:. Skal i teorien være mulig da den også bruker SDL, men fikk det ikke til å fungere). Når jeg logget ut og inn ble denne variabelen slettet og alt fungerte.

 

Som Homer Simpson ville sagt, d'oh!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...