Gå til innhold

Foto

Excel Timeliste hvor jeg vil finne timer mellom visse klokkeslett


2 svar i denne tråden

#1 Solsviken

Solsviken

    Bruker

  • EKSTRA
  • Medlemmer
  • 1 581 innlegg
  •   9. oktober 2002

Skrevet 8. januar 2011 - 19:02

Jeg jobber i en skift jobb og trenger litt hjelp til oppsett av en excel fil.

La oss si vi har en simpel excelfil,
Kolonne A: Klokkeslett inn
Kolonne B: Klokkeslett ut
Kolonne C: Total timer

Ganske enkelt så langt, men så kommer det vanskelige

Kolonne D: Antall timer mellom 06:00 - 14:00
Kolonne E: Antall timer mellom 14:00 - 18:00
Kolonne F: Antall timer mellom 18:00 - 01:00
Kolonne G: Antall timer mellom 01:00 - 06:00

Bare diktet opp noen tider her nå, poenget med denne listen er at jeg skal klare å holde en bedre oversikt over alle skift tilleggene.

La oss si jeg jobber 06:00 -> 16:00
Da vil mitt ønsket resultat bli:
Kolonne A: 06:00
Kolonne B: 16:00
Kolonne C: 10
Kolonne D: 8
Kolonne E: 2
Kolonne F: 0
Kolonne G: 0

Er det noen av dere excel eksperter som kan hjelpe meg her ? :)
Setter stor pris på eventuelle forslag.
  • 0

#2 Harald Staff

Harald Staff

    Bruker

  • Medlemmer
  • 2 090 innlegg
  •   25. april 2005

Skrevet 9. januar 2011 - 10:51

Hei

Du sier ingenting om Excelversjon eller språkversjon. Det er lettere å hjelpe deg hvis du gir med de opplysningene.

Norsk Excel, tid mellom 17:00 og 20:00:

=HVIS(B1="";"";MIN(STØRST(B1+(B1<A1);17/24);20/24)-MIN(STØRST(A1;17/24);20/24))

Engelsk:

=IF(B1="";"";MIN(MAX(B1+(B1<A1);17/24);20/24)-MIN(MAX(A1;17/24);20/24))

(Fjern eventuelle linjeskift)

En time er 1/24, derfor delingen i formlene. Opererer du med halvtimer så bruk 48-deler, kvarter 96-deler osv.

Stedet du får problemer er intervallet hvor du runder midnatt, eksempelvis tid mellom 22:00 og 02:00. Det enkleste og mest oversiktelige er å dele opp og løse det med vanlig addisjon, altså tid mellom 22:00 og 24:00 + tid mellom 00:00 og 02:00.

Edit: Ser nå at du ber om resultatet som heltall/desimaltall og ikke tid. Vet ikke hvor bevisst det er, men i så fall ganger du bare resultatet av formelen min med 24 og formaterer cella som "standard". Du må i alle fall gjøre dette hvis du skal gange tid med timepris, siden 1 time er 1/24 og ikke 1:

Lønn = Tid * timepris * 24

HTH. Beste hilsen Harald

Dette innlegget har blitt redigert av Harald Staff: 9. januar 2011 - 10:55

  • 0

#3 Solsviken

Solsviken

    Bruker

  • EKSTRA
  • Medlemmer
  • 1 581 innlegg
  •   9. oktober 2002

Skrevet 9. januar 2011 - 14:45

Harald staff : takk for svar, er akkurat slik jeg er på jakt etter!

Jeg har norsk Excel 2010, jeg har vakter som ikke går opp i heltall, forøvrig med natt kan jeg f.eks bruke 25:00 istedenfor 01:00 for å unngå den midnatt skiftet.

Jeg skal teste formelen du gav meg når jeg kommer hjem i 2100 tiden. Igjen takk for svar
  • 0


0 bruker(e) leser denne tråden

0 medlemmer, 0 gjester, 0 skjulte brukere