Jump to content
Sign in to follow this  
wil

Mus fungerer ikke etter Rekompilering av kjerne?

Recommended Posts

Hei. Her om natta tok jeg å reokmpilerte kjernen, eller rettere sagt. Jeg oppgraderte den via upgradepkg. Jeg hadde lasta ned både linux-2.4.33 og 2.6.17.8 i tgz format på forhånd. Først prøvde jeg å oppgradere til 2.4.33. Det den gjorde da var å installere alt som hadde med 2.4.33 kjernen å gjøre. Hjelpes det var mye. Tok vel 2-3 timer i alt tror jeg. Det så ut til å fungere fint.

Så tenkte jeg bare for å prøve da, så skulle jeg oppgradere til 2.6.17.8. Det tok enda lengre tid. 3-4 timer kanskje. Så holdt jeg på å falle av stolen når skjermen ble svart når jeg skrev reboot etterpå. Så jeg slo maskina av og slo den på igjen, og det fungerte som normalt, men en ting var litt rart. Musa fungerer ikke etter at jeg rekompilerte til siste kjernen.

Eller jo, musa er der (Musperkern), men den vil ikke røre på seg. Når jeg drar musa frem og tilbake så skjer det ingenting.

 

Noen som vet hvordan jeg får løst det problemet? Kunne tenkt meg å løst dette problemet når jeg har den nyeste kjernen, siden at det tok såpass lang tid å rekompilere den.

Kanskje litt unødvendig og si det, men jeg har Slackware 10.2 som Distro :)

 

Håper på mange svar.

Share this post


Link to post

Finn ut kva modul musa brukar, ta eit google søk, pass på at den blir lagt inn i config fila til X.

Kanskje det er så enkelt at du kan køyre xorgconfig for å få det ordna.

Share this post


Link to post

Eg tipper på at du enten har gløymt å legge inn støttefor mus i kjernen, eller at den har bytta device, og du ikkje har oppdatert xorg.conf.

 

BTW: du sliter jo noko voldsomt/har ikkje kontroll med å kompilere kjerner... Kvifor bruker du ikkje ein av binærpakkane til slack istadenfor?

Share this post


Link to post

Hadde samme problem som deg, men musa mi var av USB typen, og jeg hadde glemt å legge inn støtte for USB 2.0. Husker ikke hva modulet het. Men prøv med en annen PS2 mus, og sjekk.

Kanskje samme problem som meg.

Share this post


Link to post

Hei igjen. Har vært borte nå. Fant en mulig løsning på nett rett etter at jeg spurte her, men har ikke hatt tid til å prøve det enda. Om jeg har glemt å lagt inn støtte for musa vet jeg ikke, for det var ikke jeg som konfiguerte og valgte hva jeg ville ha med. Skal se om jeg får ordna det senere i dag. Takk for svarene.

Hvorfor jeg ikke har standard kjernen til Slackware? Jo det skal jeg fortelle. Det er fordi at jeg får ikke ACPI (eller hva det no heter til å fungere med 2.4.x kjernen.

Share this post


Link to post

Var det jeg lasta ned jeg å. Lasta ned den som var i Current versjonen av Slackware. Det var 2.6.17.8 som ligger i nåværende Currentversjon.

Hvis noen lurer så er det ikke USB mus jeg bruker. Bruker touchpad på laptopen min. Så prøvde jeg å koble på en PS/2 mus til laptopen, men heller ikke da fungerte det. Skal se om jeg får prøvd det jeg fant på nett så snart jeg får tid.

Edited by wil

Share this post


Link to post

Kvifor skriv du at du har rekompilert kjenen da wil, når du ikkje har gjort det?

Prøv å forandre device i xorg.conf. Er ikkje utenkelig at musa har skifta navn. Sjå også etter om driveren for musa er bygd som modul, og om den vert lasta.

Share this post


Link to post
Uffda. Sorry, burde kanskje skrevet uppgradert kjernen istede :blush:

6707510[/snapback]

Hvordan kan det ta 3-4 timer å oppgradere kjernen? Bruker du en 286? :)

Share this post


Link to post

Ja, nå skrev jeg bare Upgradepkg linux-2.6.17.8 osv da. Også begynte den, og etter det skrev jeg det vanlige. bzImage først, så make modules, også make modules_install.

 

Da la den visstnok inn alt som hadde med linux-2.6.17.8 å gjøre. Så jeg vet ikke helt jeg.

Share this post


Link to post

Trur ikkje eingong at wil veit det.

Kan det være ein .src.tgz han har lasta ned? Eller la han først inn binærpakken, for så å gå til kildetreet og dra ein make o.s.v.

Share this post


Link to post

lasta ned denne fila:

 

kernel-source-2.6.17.8-noarch-1.tgz

 

og kjørte en upgradepkg kernel-source-2.6.17.8-noarch-1.tgz, og da ble den oppgradert.

 

når jeg hadde kjørt den, så kjørte jeg deretter make bzImage, så make modules og tilslutt make modules_install.

 

 

PS: At du ikke forstår hva jeg skriver kan IKKE bli mitt problem.

Share this post


Link to post

men uannsett: rådet til Olear fungerte. Kjørte en modprobe psmouse, og da fungerte musa på laptopen. Tusen takk, Olear.

Share this post


Link to post
lasta ned denne fila:

 

kernel-source-2.6.17.8-noarch-1.tgz

 

og kjørte en upgradepkg kernel-source-2.6.17.8-noarch-1.tgz, og da ble den oppgradert.

 

når jeg hadde kjørt den, så kjørte jeg deretter make bzImage, så make modules og tilslutt make modules_install.

Ok, hvis du ikker gjorde noen forandringer har du en veldig strippet kernel, last ned denne konfigen: ftp://ftp.slackware.no/linux/slackware/sl...test26.s/config

 

PS: At du ikke forstår hva jeg skriver kan IKKE bli mitt problem.

Hvis du vil ha hjelp så lønner det seg å bli forstått, så det er DITT problem.

Share this post


Link to post

Jepp ..... Men er ikke nødvendig da den er for 2.6.17.8, er usikker på om psmouse er kompilert inn i kernelen, men er ikke verre en å gjøre dette selv.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...