Gå til innhold

Foto

[Løst] [Ubuntu] "Gtk-Warning **: cannot open display" Hvordan få display til å fungere?


17 svar i denne tråden

#1 praut86

praut86

    Bruker

  • Medlemmer
  • 623 innlegg
  •   16. januar 2003

Skrevet 6. januar 2014 - 17:18

Hei. Jeg lurer på om noen her har noen tips på hvordan jeg får display til å fungere? Dette gjelder nyeste Ubuntu server (13.10).

 

Dette har jeg gjort:

 

* X11 forwarding er enabla i sshd_config

* Aktivert X11 forwarding i Putty 

* Xming er startet på en Windows 7 pc.

 

 

Brukerkontoen jeg tester med får denne feilmeldingen:  Gtk-WARNING **: cannot open display: .

 

Det er Xchat jeg prøver å få til. Det som er noe snodig er at det fungerte før jeg oppgraderte til nyeste Ubuntu versjon.

 

Håper på svar  :)

 

 

 


  • 0

#2 Emancipate

Emancipate

    Bruker

  • Medlemmer
  • 12 461 innlegg
  •   22. mars 2006

Skrevet 6. januar 2014 - 17:24

Kanskje du finner noe her: http://unix.stackexc...ys-on-a-machine
  • 0

#3 Occi

Occi

    Bruker

  • Medlemmer
  • 6 036 innlegg
  •   28. juli 2007

Skrevet 6. januar 2014 - 18:00

Om det er Xchat du ønsker å kjøre fra en server foreslår jeg at du heller setter opp en bouncer (bnc). Eventuelt kjører en tekstklient i screen eller tmux (f. eks weechat eller irssi).


  • 0

#4 praut86

praut86

    Bruker

  • Medlemmer
  • 623 innlegg
  •   16. januar 2003

Skrevet 6. januar 2014 - 20:39

Om det er Xchat du ønsker å kjøre fra en server foreslår jeg at du heller setter opp en bouncer (bnc). Eventuelt kjører en tekstklient i screen eller tmux (f. eks weechat eller irssi).

 

Takk for svarene. Hvordan får jeg irssi i screen egentlig? Har aldri prøvd meg på det før. Kan sette opp bnc, men vil heller prøve irssi m/screen. Har egentlig lagt den display-saken litt på vent.


  • 0

#5 Occi

Occi

    Bruker

  • Medlemmer
  • 6 036 innlegg
  •   28. juli 2007

Skrevet 6. januar 2014 - 20:57

Takk for svarene. Hvordan får jeg irssi i screen egentlig? Har aldri prøvd meg på det før. Kan sette opp bnc, men vil heller prøve irssi m/screen. Har egentlig lagt den display-saken litt på vent.

Jeg lagde faktisk en kort videoguide for hvordan du bruker både Screen og irssi for en stund siden, den bør gi deg en ganske god idé! :) Merk at som beskrivelsen nevner så bruker jeg vanligvis WeeChat.

 

 

 

Showing the usage of the IRC client irssi running in a Screen. Handy to let your client run in a detachable session on your server so you'll always be connected.

Personally I prefer WeeChat over irssi, but whatever works for you is fine. If you can't remember how to reattach, add an alias to your bashrc: alias irc="screen -raAd irc"

Video made using ffmpeg and screenkey.

Done on a temporary VM on Digital Ocean, so don't bother trying to hack this even if you got the IP and I stupidly ran this session as root :-)


Dette innlegget har blitt redigert av Occi: 6. januar 2014 - 20:59

  • 0

#6 praut86

praut86

    Bruker

  • Medlemmer
  • 623 innlegg
  •   16. januar 2003

Skrevet 6. januar 2014 - 21:27

Takker :) Dette skal prøves. :)


  • 0

#7 praut86

praut86

    Bruker

  • Medlemmer
  • 623 innlegg
  •   16. januar 2003

Skrevet 7. januar 2014 - 18:42

Jeg sliter med å få bokstavene æøå til å vises rett, når jeg har screen irssi.

 

Hvilke instillinger må man ha i Putty, samt Irssi for å få vise bokstavene nevnt overfor rett?

 

Fann noe om det på nettet, men jeg fikk dette ikke til.

 

Håper noen kan hjelpe meg her. :)


  • 0

#8 Sokkalf™

Sokkalf™

    Bruker

  • Medlemmer
  • 5 992 innlegg
  •   2. november 2003

Skrevet 7. januar 2014 - 18:47

Har du satt tegnsettet til putty til UTF-8? Mener den bruker ISO-8859-1 som default.


  • 0

Hortz fur dëhn stëkehn west!
--- ugle-z.no --- github --- ubuntu --- fedora --- debian --- openSUSE --- FreeBSD ---

59°93'N 10°74'E


#9 Occi

Occi

    Bruker

  • Medlemmer
  • 6 036 innlegg
  •   28. juli 2007

Skrevet 7. januar 2014 - 18:53

Som Sokkalf sier, sett PuTTY til UTF-8. irssi respekterer encoding til environment, så det holder å sette unicode i Screen med `screen -U` som vist i videoen.


  • 0

#10 praut86

praut86

    Bruker

  • Medlemmer
  • 623 innlegg
  •   16. januar 2003

Skrevet 7. januar 2014 - 19:07

Har satt utf-8 i putty samt gjort det som var i videoen, men bokstavene vises ikke rett fortsatt.

 

Jeg har også prøvd : /SET term_charset utf-8 og /save, samme greia der også.

 

Hva annet kan jeg prøve?


Dette innlegget har blitt redigert av praut86: 7. januar 2014 - 19:07

  • 0

#11 Occi

Occi

    Bruker

  • Medlemmer
  • 6 036 innlegg
  •   28. juli 2007

Skrevet 7. januar 2014 - 20:53

Hva gir `locale` i en Screen session? Funker det utenfor screen? Er det kun problemer inni irssi? Og det stemmer at skal/bør kjøre `/SET term_charset utf-8`, hadde bare glemt det av.
 


  • 0

#12 praut86

praut86

    Bruker

  • Medlemmer
  • 623 innlegg
  •   16. januar 2003

Skrevet 7. januar 2014 - 21:30

"locale" i en Screen session, så får jeg opp norsk språk "LANG=nb_NO.utf8".

utenfor screen fungerer det, men ikke inni irssi.

 

Putty har utf-8 samt /SET term_charset utf-8 i irssi.

 

Har endret systemspråk til Norsk (var Engelsk), men det forandret ikke noe i irssi.


  • 0

#13 Occi

Occi

    Bruker

  • Medlemmer
  • 6 036 innlegg
  •   28. juli 2007

Skrevet 7. januar 2014 - 22:45

Hvilken versjon av irssi har du? For 0.8.9 og eldre er det  /SET term_type utf-8


  • 0

#14 praut86

praut86

    Bruker

  • Medlemmer
  • 623 innlegg
  •   16. januar 2003

Skrevet 7. januar 2014 - 23:06

irssi v0.8.15 er den jeg har installert.


  • 0

#15 Occi

Occi

    Bruker

  • Medlemmer
  • 6 036 innlegg
  •   28. juli 2007

Skrevet 8. januar 2014 - 03:04

Da er jeg litt ute av ideer, sorry.


  • 0

#16 praut86

praut86

    Bruker

  • Medlemmer
  • 623 innlegg
  •   16. januar 2003

Skrevet 8. januar 2014 - 21:21

Da er jeg litt ute av ideer, sorry.

 

Jeg fikk det til med litt googling  - http://xkr47.outersp...utf-8-guide.txt

 

Putty er satt opp med ISO-8859-1 og jeg har gjort det som står på den siden.

Jeg fikk det ikke til på den kontoen jeg tenkte å bruke, men fikk til bokstavene på testkonto. (Noe galt med den første kontoen jeg testa på?) 

 

 

Takk for alle tips/svar jeg har fått  :)


Dette innlegget har blitt redigert av praut86: 8. januar 2014 - 21:22

  • 0

#17 Occi

Occi

    Bruker

  • Medlemmer
  • 6 036 innlegg
  •   28. juli 2007

Skrevet 8. januar 2014 - 21:43

Godt å høre. Vet ikke om du anser tråden din som løst eller ei jeg men. Som et lite tips til kan jeg nevne at Cygwin som gir deg bash på Windows har en ganske mye bedre terminal enn PuTTY, og har en standard OpenSSH klient. Lettere å endre farger og slikt hvis man ønsker det. Fargene jeg bruker når jeg sitter på Windows/Cygwin.


Dette innlegget har blitt redigert av Occi: 8. januar 2014 - 21:44

  • 0

#18 praut86

praut86

    Bruker

  • Medlemmer
  • 623 innlegg
  •   16. januar 2003

Skrevet 8. januar 2014 - 22:25

Ok :) Ja, jeg anser saken som løst.

 

Takker for alle tips/svar :)


  • 0


0 bruker(e) leser denne tråden

0 medlemmer, 0 gjester, 0 skjulte brukere